Tempo aproximado para leitura: 00:00:50 min
Ocorrência
No Aplicativo Minhas Vendas disponível para Android ou IOS, ao tentar realizar o login é apresentada a mensagem Erro ao definir versão da API.
Ambiente
Cross Segmentos - Linha Datasul - APP Minhas Vendas - Todas as versões
Causa
Esse incidente ocorre devido a falta de parametrização para utilização do Aplicativo Minhas Vendas.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. No menu TOTVS procure e execute o programa totvs-mcd-appconf.applications - Configuração de Aplicações;
2. Verifique se o registro com nome App Minhas Vendas está com o campo Ativo igual a Sim.
Caso não esteja ativo, por meio do botão ..., opção Editar, marque o campo Aplicação Ativa? igual a Sim e acione o botão Salvar;
3. Relacionar o Aplicativo Minhas Vendas (5204) à empresa utilizada através do programa BTB962AA - Parâmetros do Foundation, conforme demonstrado a seguir:
A partir da versão 12.1.2411, a tela acima foi atualizada e implementada em HTML, sendo assim, busque por Empresas do Foundation (HTML) no menu TOTVS.
Ao abrir o programa Empresas do Foundation, posicione na empresa a qual o erro se refere e no canto direito clique no botão ... e então clique na opção Cadastros Relacionados.
Posicionar na pasta Servidores de Aplicação e clicar no botão Adicionar.
Acima exemplo de configuração em tela HTML.
Importante
Aplicativo está relacionado ao Código de Aplicação do Aplicativo Minhas Vendas (5204), Alias deve-se informar * e Servidor de Aplicação informar o nome do servidor de aplicação que atende a requisição, podendo estar no formato Appserver Ex: Appserver://meuserver:5132/NovoFrame ou PASOE Ex: http://meuServer:8085/apsv.
Saiba mais
Mais informações sobre o Broker escalável estão disponíveis no link: TOTVS Broker Escalável.
1 Comentários