Tempo aproximado para leitura: 00:03:00 min
Ocorrência
Ao tentar transmitir os eventos S-2205 - Alteração Cadastral, o governo retorna a inconsistência:
Código da Resposta: 304 - Não existe um Contrato de Trabalho para o CPF 'XXX' ou este encontra-se encerrado na data do evento
Exemplo:
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal – Todas as versões
Causa
Esse erro ocorre em 03 situações:
- Está querendo enviar a alteração cadastral, mas o evento mas o S-2200 ou não foi enviado ao governo;
- Está querendo enviar a alteração cadastral com a data anterior a data de admissão do funcionário;
- Está enviando a alteração cadastral após a data de demissão do funcionário.
Solução
- Acesse o cadastro do funcionário no TAF e veja se o registro S-2200 esta com numero de recibo informado. Caso não esteja precisa verificar se o S-2200 está inconsisteste, ajustar e enviar a admissão. Somente após o envio da admissão é possivel enviar a alteração cadastral.
- Como o ingresso dele na empresa ainda não ocorreu o CPF dele realmente não estará vinculado a empresa, sendo assim nesse caso precisa gerar a alteração cadastral com data de alteração após a data de admissão dele.
Exemplo: Admissão em 10/05/2023, está enviando o S-2205 com data de alteração em 09/05/2023, um dia antes da data inicial dele na empresa, logo nessa data ainda não existe um contrato de trabalho para esse trabalhador. - Como a rescisão dele já ocorreu esse contrato de trabalho já se encontra encerrado, não podendo assim gerar essa alteração, sendo assim precisa excluir o S-2205 que esta com inconsistencia.
Exemplo: Rescisão em 10/05/2023, e está enviando o S-2205 com data de alteração em 15/05/2023, Cinco dias após o desligamento dele na empresa.
Saiba Mais
Para saber mais consulte os links abaixo:
MOS - Manual de Orientação eSocial
Perguntas Frequentes site eSocial
eSocial | Protheus - Entregas Legais
Agenda de Eventos Tira-Dúvidas / Responde [Suporte Padrão
Essa documentação também pode ser acessada 24h, através da Carolina: Carolina - Assistente Virtual - Como usar a Carolina pelo ícone no produto Protheus
0 Comentários