Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS CS - COCTAGR - Gravação de documento do contrato no Banco de Dados

time.png Tempo aproximado para leitura: 00:02:20 min

Ocorrência
No módulo Contratos Agrícolas - COCTAGR, realizar processo para configurar uma gravação de documento do contrato no banco de dados é apresentada a ocorrência Gravação de documento do contrato no Banco de Dados.

Ambiente
TOTVS Agro – TOTVS Agro – Bioenergia – Contratos Agrícolas - COCTAGR – Versão 12

Causa
Esse incidente ocorre, pois é preciso editar um contrato que está com o status de erro no processo.

Solução
Para solucionar essa ocorrência, siga os seguintes passos:

1. Configure os parâmetros abaixo no aplicativo PAR_PIMS - Parâmetros PIMS;

GRA.png

SeçãoGERAIS, Entrada FG_TP_GRAV_DOCS e Valor B;
Seção: GERAIS, Entrada DE_ARQ_JAR_DOCTOS e Valor informe o diretório do arquivo PIMSDoc.jar;
Seção: GERAIS, Entrada DE_ARQ_JAR_JAVA e Valor  informe o diretório do Java, ex.: C:\Java\jdk1.6.0_45\bin\java.exe;

2. Abra o arquivo PIMSDoc.jar com o aplicativo 7-zip, por exemplo, e navegue até o diretório parameter \PimsDoc.jar\br\com\totvs\agroindustria\pimsdoc\parameter\;

GRA1.png

GRA2.png

3. Abra o arquivo config.properties que fica dentro da pasta parameter;

GRA3.png

4. Configure a string de conexão com o banco de dados no arquivo config.properties exemplo thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=brjunsrv4ora-scan)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=REDRIVER_PRODUCAO)));

GRA4.png

5. Abra o CMD - Prompt de Comando do Windows e acesse o diretório bin do Java, para isso, digite o comando cd C:\Java\jdk1.6.0_45\bin, clique em Enter. Em seguida, execute o comando java -jar C:\PimsDoc\PimsDoc.jarencryptUsuário, clique em Enter para criptografar o usuário troque o diretório C:\PimsDoc\PimsDoc.jar pelo diretório do PIMSDoc e Usuário pelo usuário do banco repetindo o mesmo procedimento para criptografar a senha.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _