Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - UFN - Ao abrir arquivo CSV no Excel está perdendo a formatação

time.png Tempo aproximado para leitura: 00:03:06 min

Ocorrência
Quando abrimos o arquivo .CSV (Comma Separated Values) no Excel está perdendo a formatação.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Financeiro Universal (UFN) – Versão 12

Causa
Isto ocorre
, pois ao abrir diretamente o arquivo no Excel, o mesmo assume uma formatação padrão geral. O problema não tem relação com o arquivo .CSV gerado pelo Sistema, pois ele é um arquivo texto. Ao abrir o arquivo .CSV em um editor de textos é possível verificar que não há perda de formatação.

Solução
Para solucionar essa ocorrência, o arquivo .CSV não deve ser aberto diretamente, ele deve ser importado no Excel, segue abaixo tutorias da Internet informando como deve ser feita a importação para manter a formação da coluna:

1. Tutorial Simples: Como abrir arquivos CSV no Excel sem perder a formatação

2. Artigo da Microsoft: Manter os zeros à esquerda e números grandes

No site da Microsoft, existe a explicação para essas situações de formato de arquivo CSV.
Título: Importar ou exportar arquivos de texto (.TXT ou .CSV)
LinkImportar ou exportar arquivos de texto (.txt ou .csv)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _