Tempo aproximado para leitura: 00:03:03 min
Ocorrência
Ao acessar o produto Datasul é apresentado erro interno e não é apresentada a tela de Login do produto. Ao verificar o log do Tomcat, são identificados erros similares a:
com.totvs.framework.progress.connector.ProgressConnectionRuntimeException:
Código do broker de conexão inválido para a Empresa: 1 Aplicativo: * Alias: *!
Verifique as configurações da empresa nos Parâmetros do Foundation (BTB962AA).
Ambiente
Framework - Framework (Linha Datasul) - Básico BTB - Todas as versões
Causa
A situação reportada acima ocorre devido a falta do cadastro geral do Broker Escalável no produto Datasul, sem esta informação o produto Datasul não possui a informação de qual Appserver deverá realizar o consumo dos dados.
Solução
Para este cenário teremos duas soluções possíveis, para isso, o primeiro passo seria gerar o dump de dados da tabela cadastro_appserver e avaliar o seu conteúdo.
1. Caso não contenha dados na tabela cadastro_appserver, basta acessar o programa Parâmetros do Foundation - btb962aa. Detalhes deste processo na sessão saiba mais.
2. Caso já tenha algum Broker Escalável cadastrado, como por exemplo do RPW, porém não tenha o Broker geral, siga os passos abaixo:
- Baixe o programa de acerto aqui;
- Descompacte o programa desejado e copie para a pasta c:\temp;
- Acesse o proenv do Progress, exemplo: c:\dlc117\bin\proenv.bat;
- Informe a linha de comando a seguir, onde o comando prowin32 abrirá o editor Progress, o caminho\aquivo.pf corresponde ao arquivo pf do seu produto e o caminho\arquivo.ini corresponde ao seu arquivo ini do produto e por fim XX do nome do programa Acerto-cadastro_appserver-Progress_XX corresponde a versão do Progress;
prowin32 -pf caminho\aquivo.pf -ini caminho\arquivo.ini -p c:\temp\Acerto-cadastro_appserver-Progress_XX.r
Para identificar o cadastro de um Broker Escalável geral, o mesmo deverá conter o Alias e Aplicativo com o valor *, segue exemplo de um registro:
"1" "*" "*" "AppServer://JVN019401849:5162/totvs-brk-FND" 0
Saiba mais
Para obter informações de geração de um dump de dados, acesse o artigo Framework - Linha Datasul - TEC - Como gerar dump de dados de uma tabela Progress.
Para realizar o acerto do Broker Escalável com a tabela cadastro_appserver vazia, siga os passos do artigo Framework - Linha Datasul - TEC - Após aplicação da release 12.1.34, ao acessar o produto é apresentada a mensagem de indisponibilidade do Servidor de Aplicação Progress.
O Documento de Referência para essa funcionalidade está publicado no link Broker Escalável
0 Comentários