Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Erro Could not allocate space for object dbo in database because the PRIMARY filegroup is full

time.png Tempo aproximado para leitura: 00:02:22 min

Ocorrência
Ao executar determinadas rotinas no produto Datasul apresenta a mensagem no log:

37000: [Microsoft][SQL Server Native Client 11.0][SQL Server]Could not allocate space for object 'dbo.SORT temporary run storage: 140737649115136' in database 'tempdb' because the 'PRIMARY' filegrou
p is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.


Ambiente
Framework - Framework (Linha Datasul) - SQL Server - Todas as versões

Causa
Esta inconsistência é apresentada quando não existe espaço em disco para crescimento do banco de dados SQL Server. Os erros apresentados também ocorreram, quando o arquivo de log .ldf ou arquivo primário .mdf do banco ultrapassou o valor máximo atribuído.

Solução
Inicialmente verificar o espaço em disco. Após ajustar os parâmetros do banco de dados SQL Server. Lembrando que há um limite de 10 GB para o SQL Server Express 2008 R2 e versões posteriores.

Nossas recomendações são as seguintes:
RECOVERY MODEL: simple
AUTO GROWTH: unrestricted growth by 10%
MAXIMUM FILE SIZE: Unlimited

Em Propriedades do Banco de Dados, na opção Arquivos:

Tela1.png

Tela2.png

Tela3.png


Estas recomendações são apenas um direcionamento básico para uma boa operação do servidor de banco de dados e não deve ser considerado como único padrão de avaliação, monitoração, e configuração do banco de dados que deve ser realizado por o DBA - Administrador de Banco de Dados responsável.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _