Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - PON - Ao incluir uma visita ocorre error log de chave duplicada na tabela SPY

time.png Tempo aproximado para leitura: 00:05:00 min

Dúvida
Ao incluir uma visita (Atualizações>Cadastro de Visitantes>Visitas), ocorre error log "SPY010: DB error (Update): -29 File: SPY010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server] Não é possível inserir uma linha de chave duplicada no objeto 'dbo.SPY010' com índice exclusivo"

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa
Esse incidente pode ocorrer por conta do campo PY_NUMERO, que guarda o número da visita, estar repetindo os códigos. Isso pode ser causado por configuração incorreta dos campos da tabela SPY, falta de atualização do ambiente ou controle de numeração da tabela SPY incorreto.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Verifique no dicionário de dados da tabela SPY, via SIGACFG, a configuração do campo PY_NUMERO, que deve seguir a estrutura abaixo;






2. Se o campo estiver correto, verifique se as ordens dos campos na tabela SPY estão corretas, conforme o padrão, abaixo:


3. Verifique se os índices estão conforme abaixo:


4. A numeração da visita, é gerada de forma automática, assim, verifique também no Configurador, o controle de numeração da tabela SPY, a numeração deve seguir o mesmo tamanho do campo PY_NUMERO, ou seja, com tamanho 9.
 
5. O ambiente deve estar atualizado, sendo necessário aplicar no ambiente o último Pacote de Expedição contínua de RH, LIB e Binário, conforme links abaixo.

Binário - Appserver
Binário - SmartClient

Saiba Mais
Manual do Ponto Eletrônico
Pacote de Expedição Contínua Acumulado de RH


Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _