Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - O que verificar quando o sistema apresenta no log: Nenhum agente de grid disponível no momento.

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
O que verificar quando o sistema apresenta no log: Nenhum agente de grid disponível no momento.


Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - Todas as versões.

Causa
Esse incidente ocorre por alguma parametrização indevida ou por falta de atualização das rotinas do GPE.

1 - Configuração no appserver.ini (framework);

2 - Atualização das rotinas do GPE (Responsabilidade do módulo);
3 - Configuração dos parâmetros (Configuração do módulo);
4 - Processamento da rotina (realizado pelo módulo);

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Parametrização do appserver.ini (framework) ; https://tdn.totvs.com/display/public/framework/GridServer+-+Como+configurar 

Definição das pastas: Appserver e Slave 1;

Definição do arquivo.ini do SERVER:

Definição do arquivo.ini do SLAVE:


2. Certifique-se de que o ambiente está devidamente atualizado com o último pacote de expedição contínua e a lib disponíveis no portal do cliente:;

https://suporte.totvs.com/portal/p/10098/download#000006/P2210/P2210AP/ 

https://suporte.totvs.com/portal/p/10098/download#000006/368/TFLIB/ 

 

3. Verifique a definição dos parâmetros pertinentes ao módulo RH:

https://centraldeatendimento.totvs.com/hc/pt-br/articles/4402890654999 

MV_GRID - Indica se utilizará GRID no Cálculo da Folha
MV_GPEGRID
 - Caso MV_GRID ativado, habilita rotinas p/ Grid: 1=Provisão, 2=Cálculo Folha/13o., em branco=Todas as opções
MV_REGGRID
 - Indica o numero de registros a serem processados por Thread no calculo com GRID
MV_MINGRID - Desliga o GRID automaticamente se o numero de funcionários a ser processado for menor que o numero definido neste parâmetro

A demonstração foi realizada com as seguintes definições:

 

4. No processamento da rotina, suba o appserver do GridServer e do SlaveServer;

Analise se no appserver é apresentada a conexão conforme imagem abaixo:

Após essa verificação já é possível rodar o cálculo da folha de pagamento através da rotina GPEM020:

Cálculo realizado com sucesso!

 

Saiba mais:

RH - Folha de Pagamento

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _