Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Logix - CAD - Mensagem de erro -136 sobre extents de tabela

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Quando em qualquer rotina ocorrer o erro -271, -136, é um erro do banco de dados.
Essa mensagem se refere aos extents da tabela no banco Informix
No exemplo abaixo o erro ocorreu na inclusão da tabela ctb_lanc_ctbl_vdp:

erro_cadastro.jpg


Ambiente

Cross Segmentos - TOTVS Backoffice (Linha Logix) - Cadastro - Versão 12

Causa
No banco Informix ao ocorrer um erro de banco são exibidos dois códigos. No exemplo citado são os códigos -271 e -136. O primeiro código refere-se ao problema ocorrido, e o segundo código refere-se à causa do problema. 

STATUS: -271
MSG: Could not insert new row into the table. sqlerrm(ctb_lanc_ctbl_vdp)
ISAM: -136
-136 ISAM error: no more extents.

O erro -136 é um erro de extents de tabela do banco, pode ser causado por um problema de espaço no banco ou um problema de fragmentação da tabela:

Solução
Para solucionar precisa desfragmentar a tabela em que estiver ocorrendo o erro. No exemplo citado é a tabela ctb_lanc_ctbl_vdp.
Caso a desfragmentação não solucionar deve acionar um DBA de banco de dados para analisar a situação.

  

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _