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Cross Segmentos - Linha Datasul - MPD - Lentidão ou travamento do PD4000 Progress

time.png Tempo aproximado para leitura: 00:02:05 min

Ocorrência
Na execução do PD4000 - Implantação Pedidos o Sistema apresenta lentidão ou travamento.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Pedidos de Vendas (MPD) - Todas as versões

Causa
A lentidão ou o travamento no PD4000 precisa ser avaliada pontualmente em cada caso. 

Solução
Para avaliação deste cenário, realize os seguintes passos:

1. Recomendamos inicialmente fazer um teste retirando quaisquer específicos e triggers do seu ambiente para que assim possamos isolar se o problema está no produto padrão ou em programas específicos; 
2. O parâmetro Quick Start -q do arquivo de parâmetros da sessão *.pf, quando habilitado, agrega ganho de performance na execução de rotinas que exigem uma quantidade de recursos elevada, onde são instanciados grande número de programas. No caso das rotinas de fechamento, ainda podemos destacar, além da quantidade de programas utilizados, a recursividade na utilização dos mesmos. Portanto, o parâmetro -q deve ser mantido ativo junto aos arquivos de parâmetros das sessões *.pf. Caso exista a necessidade de desativá-lo para alguma aplicação, recomenda-se a criação de novos atalhos para estas finalidades, para os quais o parâmetro poderá ser desativado; 
3. Caso a lentidão persista, solicitamos a realização de uma nova simulação gerando todos os arquivos listados a seguir a partir do mesmo teste; 
4. Gravar um vídeo demonstrando a simulação;
5. Ativar o Extrato de Versão no programa btb100aa - Gerenciador de Clientlog;
6. Ativar o Client.log no btb100aa;
7. No programa de Análise de Performance executado a partir do botão de Ajuda > Suporte > Profiler digitar PD4000 no campo Programa e Executar. Será gerado um arquivo com a extensão .out no diretório informado;
8. Fazer a simulação;
9. Desativar os logs e extrato;
10. Exportar o pedido por meio do programa spp\ftp\spft800.r;
11. Enviar todos os arquivos gerados no ticket para análise da equipe de Suporte. 

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