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Ocorrência
Os registros de movimentação do produto e as tabelas de saldo não conferem entre si.
Exemplo SB2 X SB8 X SBF X SD5 etc.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Primeiramente é importante conferir se de fato há um cenário de desbalanceamento, propriamente.
Há situações onde apenas não foram parametrizados os relatórios de forma compatível para o cenário, gerando a falsa impressão de haver desbalanceamento.
Recomendamos a extração do relatório MATR282 parametrizado como indicado no link a seguir para identificação de possíveis divergências reais de saldos entre as tabelas: SIGAEST - MATR282 - Parametrização para identificar divergência de saldos entre tabelas SB2 X SB8 X SBF
Caso demonstre, de fato, divergência de saldo entre as tabelas, verifique se está enquadrado em algum destes cenários:
- Tratamento correto de desbalanceamento de tabelas de Lote e Endereço em todos os cenários
- Dicas de Analise de divergência de Saldo Atual/Posição de produtos com controle de Lote e Endereço
- Dicas de Analise de divergência de Saldo Atual/Posição de Saldo em Estoque
Do contrário, atente-se às instruções a seguir.
Solução
Apenas com base na visualização de registros inconsistentes, já gravados nas tabelas, não há ação concreta para correção no Produto Protheus ou Suporte no Produto.
Para Suporte e correção no Produto (e consequentemente nas tabelas) é necessário mapear a rotina/ processamento padrão do sistema que estaria ocasionando tal problema.
Ou seja, é necessário identificar quais os processos são realizados no Protheus que resultam num possível erro sistêmico (e deste modo ser gerada uma correção na rotina que estaria processando um resultado indevido).
Não há atualmente uma "correção pronta" específica para tal situação "processamento X grava um saldo incorreto na tabela". No cenário comum os saldos demonstrados no sistema resultam de acordo com as diferentes formas de movimentações de entrada e saída padrão do sistema. Para uma possível correção é necessário sinalizar qual processamento estaria resultando em cálculo incorreto.
Para isto, é necessário:
- Em ambiente de Teste realizar a validação de seu processo habitual (com um novo produto, criado exclusivamente para essa análise, sem sujeiras no histórico).
- Recomendamos que realize então as principais movimentações que fazem parte do cotidiano operacional de sua empresa. Exemplo: Lançamento de Notas de entrada do produto, saída do produto em nota de venda, entrada do produto por Ordem de Produção, transferências de saldos, baixas por OS, movimentações em poder de terceiro, etc... a fim de indicar em qual processamento fora notada falha do sistema Protheus em seu cenário.
- É recomendado que o teste seja realizado em ambiente teste atualizado e padrão (inclusive dicionários) descartando assim possíveis causas provocadas por customizações ou incompatibilidade entre fontes desatualizados os quais não possuem ação de correção/suporte.
- Acumulado SIGAEST conforme sua versão
- LIB Atual -Logo Guará | Harpia
- Appserver - Lobo Guará | Harpia R.33
- Smartclient - Lobo Guará | Harpia R.33
- DBAccess
- Como desabilitar customizações no ambiente
- Ao identificar o cenário (processos realizados no Protheus) que estaria ocasionando uma falha sistêmica em seu cenário, é recomendado que acione o canal de Suporte Protheus Estoque com as evidências e devidas particularidades do processo inconsistente, para que seja simulado e solicitada a correção do processamento.
OBS: Ao ser identificada, simulada a inconsistência de produto pelo canal de Suporte, é gerada uma solicitação de correção no sistema e, consequentemente, a área de desenvolvimento estuda o melhor modo viável para correção dos dados inconsistentes já gravados em suas tabelas em decorrência da tal falha sistêmica.
Ressalvas:
1) Caso o cliente entenda que não fora uma falha sistêmica padrão que causou o desbalanceamento de saldo (ex: entenda que pode ter sido causado por algum processo customizado; ou por indevidas manipulações de base; ou ambientes incompatíveis desatualizados, por não simular mais em ambiente atualizado com novo registro; etc...):
Neste caso, o cliente pode desejar apenas a correção dos registros em si dos respectivos saldos nas tabelas (e não a identificação/correção do processamento do sistema).
Para esta necessidade é recomendado acionar sua franquia e solicitar um consultor inloco para mapear todas as rotinas e consequentes tabelas envolvidas, e projetar de forma estruturada a manipulação dos dados inconsistentes diretamente no banco de dados, minimizando impactos. Obs: Há também como alternativa ao atendimento de sua Unidade o atendimento tarifado da área HUB Plataformas a qual deve ser acionada para obtenção de orçamento. Importante: Ambas as alternativas se tratam de atendimento tarifado. O canal de Suporte Protheus não atua na análise ou manipulação de dados nas tabelas, conforme escopo
Porém, se não for este o caso, então naturalmente não é o procedimento recomendado por não ser a solução definitiva. O ideal é identificar a origem do problema, ou seja, qual o processo está resultando num cálculo incorreto como relatado antes.
2) Com foco em simular o processo inconsistente e gerar a devida correção, é disponibilizada também, se necessário, a modalidade de atendimento Consultoria do Suporte.
Pode-se recorrer a essa modalidade quando o ambiente teste do cliente (padrão e atualizado) simula o processamento inconsistente com novos registros (conforme detalhado acima), porém, o mesmo comportamento inconsistente não é obtido no ambiente do Suporte Técnico. Nesta modalidade é analisado o ambiente do cliente a fim de rastrear as particularidades cruciais ao cenário.
Detalhes aqui: Modalidades de Atendimento
Importante ressaltar que sem simular o processo inconsistente em seu ambiente (atualizado e padrão) os canais de Suporte e Desenvolvimento não terão ação, nem mesmo pela modalidade de Consultoria para análise/manipulação dos dados em suas tabelas. Por isto é essencial que siga as recomendações dadas acima a fim de simular a possível inconsistência e esta ser analisada/corrigida.
Complementar / Material de apoio
Analise os seguintes materiais que podem auxiliar na avaliação:
MATR282 - Parametrização para identificar divergência de saldos entre tabelas SB2 X SB8 X SBF
Tratamento correto de desbalanceamento de tabelas de Lote e Endereço em todos os cenários
Dicas de Analise de divergência de Saldo Atual/Posição de produtos com controle de Lote e Endereço
Dicas de Analise de divergência de Saldo Atual/Posição de Saldo em Estoque
Dicas de Análise dos Saldos no Relatório MATR460 (P7)
MATR460 (P7) - Saldo físico em Estoque Próprio negativo/divergente. O que fazer
MATR460 (P7) - Saldo em Estoque De/Em Terceiros negativo/divergente. O que fazer?
Saiba mais:
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Assista também nosso WEBINAR sobre controle de RASTRO e LOCALIZAÇÃO no qual damos mais detalhes sobre análise de dados nas tabelas.
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