Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA215 - Error : 209 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Ambiguous column name 'C6_NUM

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência
Ao processar a rotina REFAZ EMPENHOS (MATA215) apresenta o error.log abaixo

 

THREAD ERROR ([17640], *******, )  02/02/2022

: Error : 209 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Ambiguous column name 'C6_NUM'.
Error : 209 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Ambiguous column name 'C6_ITEM'.
Error : 209 (37000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Ambiguous column name 'C6_PRODUTO'.
 ( From tMSSQLConnection::GetQueryFile )
Thread ID [15700]    User [HELTON.SILVA]    IO [328681]    Tables [79]    MaxTables [79]    Comment [MATA215 - TCPIP - ThreadID(17640)]    SP [ ]    Traced [No]    SQLReplay [No]    InTran [No]    DBEnv [MSSQL/P12]    DBThread [(SPID 56,57,60)]    Started [02/02/2022 22:38:40]    IP [192.168.0.238:2351]    IDLE [ ]    InTransact [ ]    Memory [0]    Running [ROP_QUERY for 0 s.]    RCV [5235481]    SND [47454137]    TCBuild [20210202-20210930]    TCVersion [21.1.1.0]    ARCH [64]    OS [WINDOWS]    BUILD [RELEASE]   
SELECT SC6.C6_FILIAL,SC6.C6_NUM,SC6.C6_ITEM,SC6.C6_PRODUTO,SC6.C6_BLQ,SC6.C6_NUMOS,SC6.C6_QTDEMP,SC6.C6_NUMOSFA,SC6.C6_QTDENT,SC6.C6_RESERVA,SC6.C6_TES,SC6.C6_NUMLOTE,SC6.C6_CLI,SC6.C6_LOCAL,SC6.C6_LOTECTL,SC6.C6_LOJA,SC6.C6_QTDVEN,SC6.C6_OP,SC6.C6_NUMSERI,SC6.C6_LOCALIZ,SC6.C6_QTDRESE,SC6.C6_DTVALID,SC6.C6_QTDLIB,SC6.C6_PRCVEN,SC6.C6_PRUNIT,SC6.C6_VALDESC,SC6.C6_VALOR,SC6.C6_UNSVEN,SC6.C6_ENTREG,SC6.C6_DATFAT,SC6.C6_DESCONT,SC6.C6_QTDLIB2,SC6.R_E_C_N_O_ SC6RECNO,SC6TMP.RECNOSB1 SB1RECNO,SC6.C6_QTDEMP2,SC6.C6_QTDENT2 FROM SC6SB0 SC6 INNER JOIN DBO.##TMPSC00_56 SC6TMP ON SC6.C6_NUM = SC6TMP.C6_NUM AND SC6.C6_ITEM = SC6TMP.C6_ITEM AND SC6.C6_PRODUTO = SC6TMP.C6_PRODUTO AND SC6.R_E_C_N_O_ = SC6TMP.RECNOSC6 AND SC6TMP.EXISTSB1 ='1' WHERE  SC6.C6_FILIAL='01' AND SC6.D_E_L_E_T_=' '  ORDER BY  C6_FILIAL,C6_NUM,C6_ITEM,C6_PRODUTO  on A215ATUSC6(MATA215.PRX) 25/08/2021 18:07:44 line : 2752

[TOTVS build: 7.00.210324P-20211006]
Called from MA215PROC(MATA215.PRX) 25/08/2021 18:07:44 line : 1253
Called from {|LEND| MA215PROC(LBAT,OOBJ,LNEWPROC)}(MATA215.PRX) 25/08/2021 18:07:44 line : 115
Called from {|| EVAL(SELF:BACTION,@SELF:LEND,@SELF),SELF:LEND := .T. ,SELF:ODLG:END()}(MSNEWPROC.PRW) 12/11/2021 14:43:28 line : 66
Called from ::MSDIALOG:ACTIVATE
Called from MSNEWPROCESS:ACTIVATE(MSNEWPROC.PRW) 12/11/2021 14:43:28 line : 68
Called from MA215DO(MATA215.PRX) 25/08/2021 18:07:44 line : 116
Called from {|| IF(MA215DO(LBAT),FECHABATCH(), .F. ) }(MATA215.PRX) 25/08/2021 18:07:44 line : 66
Called from ::MSDIALOG:ACTIVATE
Called from FORMBATCH(MATXFUNB.PRX) 09/09/2021 22:15:11 line : 2891
Called from MATA215(MATA215.PRX) 25/08/2021 18:07:44 line : 77
Called from __EXECUTE(APLIB090.PRW) 12/11/2021 14:43:23 line : 721
Called from MDIEXECUTE(APLIB260.PRW) 12/11/2021 14:43:23 line : 924


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.


Causa
Esse incidente ocorre, no SQL 2008. Esse banco não tem mais suporte pela Microsoft e confirme link abaixo e não esta mais homologado pela TOTVS


Solução

Efetuar testes com SQL atualizado e versão homologada pela TOTVS.​ Recomendamos que faça atualização do SQL em uma base de homologação, realizar o backup das informações.

Documentação sobre os bancos homologados pela TOTVS.
https://tdn.totvs.com/display/tec/DBAccess+-+Banco+de+dados

Documentação sobre a versão de SQL 2008.
https://tdn.totvs.com/pages/releaseview.action?pageId=384578531

 

Dica: Para os casos em que não pode migrar para uma versão mais atualizada do SQL:

O recomendado ao cliente utilizar algum banco de dados homologado, ou em caso ele esteja com problema financeiro por exemplo para atualizar o SGBD, poderia esta utilizar o PostgreSQL como seu principal SGBD, este banco de dados é gratuito e não teria mais problema desse tipo.

Hoje o banco de dados postgreSQL esta muito bem documentado pela engenharia da TOTVS.

Instalado o PostgreSQL e subindo para o Protheus.
https://tdn.totvs.com/display/public/PROT/Protheus+com+PostgreSQL+-+Linux

Dicas de como Migrar o SQL Server para PostgreSQL (Passo a Passo)
https://tdn.totvs.com/pages/releaseview.action?pageId=642410484

 

Saiba Mais:
Clique aqui e veja mais artigos sobre Processamentos no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _