Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao faturar pedido para determinado cliente na rotina 1432 - Gerar Faturamento do Balcão Reserva, a rotina para de responder e perde a comunicação com o servidor
Ambiente
TOTVS Distribuição Linha Winthor - 14 - Faturamento - A partir da versão 30
Causa
O problema ocorre pois o cadastro do cliente provavelmente em modo de edição na rotina 302 - Cadastrar Clientes em alguma estação de usuário ou aberto em algum editor SQL.
Caso o cadastro do cliente esteja em edição, será apresentado a mensagem da tela abaixo, ao tentar editar e salvar o cadastro desse cliente na rotina 302:
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse a rotina 551 - Lock de Banco e verifique se há algum Editor SQL ou rotina 302 aberta na relação de processos;
2. Selecione todos os processos suspeitos e encerre através da rotina 551 - Lock de Banco conforme tutorial do link abaixo:
3. Encerre e abra novamente a rotina 1432 - Gerar Faturamento do Balcão Reserva e tente faturar novamente o pedido.
0 Comentários