Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha RM - Frame - O RM atual não suporta o License Server instalado

Framework - Linha RM - Frame - O RM atual não suporta o License Server instalado

time.pngTempo aproximado para leitura: 00:04:00 min

Ocorrência
Ao acessar uma base após conversão apresenta mensagem de erro abaixo:
Prezado Cliente, A versão atual do RM não suporta a versão atual do License Server configurado. Recomendamos a instalação do License Server Virtual de versão 1.02.009 ou superior.



Ambiente
Framework - Linha RM - Frame - A partir da versão 12.1.18

Causa
Todos os clientes que utilizam o License Server com hardlock e converterem sua base para versão 12.1.18 ou superior não conseguirão logar na mesma, devido ao endereço IP gravado na base ser o da máquina que usava o hardlock.

Solução
Para correção desta inconsistência siga um dos métodos abaixo:

Método 1

Este procedimento dever ser executado em momento oportuno, pois o sistema RM ficará indisponível.

  1. Acesse o servidor de licenças onde está instalado o License Server hardlock;
  2. Abra o menu Iniciar;
  3. Digite services.msc na caixa de pesquisa na parte inferior do menu Iniciar;
  4. Pressione Enter para abrir o utilitário Serviços;
  5. Selecione o serviço .TOTVS License Server;
  6. Clique em Parar;



  7. Acesse o sistema;
  8. Será apresentada a mensagem de falha do License Server;
  9. Execute os passos do item Troca do License Server (final deste artigo);

Método 2

  1. Em seu servidor de banco de dados;
  2. Restaure um novo backup de sua base de dados;
  3. Acesse o sistema na versão anterior;
  4. Acesse o Módulo Serviço Globais;
  5. Na aba Ambiente acesse o menu Parâmetro Globais;
  6. Em Parâmetros Globais acesse a aba License Server;
  7. No campo Endereço, informe o IP da máquina onde foi instalado o License Server Virtual;
  8. No campo Porta, informe a porta utilizada na instalação;
  9. Clique em Salvar;

    Importante
    Caso seja apresentada falha Número de Login não pode ser negativo ou vazio, siga os passos do artigo RM - Frame - Número de tentativas de Login não pode ser negativo ou vazio.

 

Troca do License Server

  1. Ao logar nesta base convertida será apresentada uma mensagem de erro referente a conexão do socket:



  2. No campo Endereço, informe o IP da máquina onde foi instalado o License Server Virtual;
  3. No campo Porta, informe a porta utilizada na instalação;
  4. Clique em Realizar Teste;
  5. Clique em Salvar Configurações;
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _