Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha RM - Frame - Aumentar quantidade de registros na visão - Servidores de aplicação

Framework - Linha RM - Frame - Aumentar quantidade de registros na visão - Servidores de aplicação

time.pngTempo aproximado para leitura: 00:03:00 min 

Ocorrência
Ao acessar telas do RM é apresentada a mensagem: O resultado da pesquisa ultrapassou o limite de registros para esta visão. Apenas os 500 primeiros registros serão exibidos:



Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM

Causa
O sistema por default permite que sejam apresentados apenas 500 registros nas visões de modo a melhorar o desempenho do sistema.

Solução
Para que sejam apresentados mais de 500 registros na visão, é necessária a criação de um servidor de aplicação com a permissão de mais registros na visão.

Para criação do Servidor de Aplicação, siga os passos abaixo:

  1. Acesse o Menu Iniciar, Serviços Globais:



  2. Na aba Serviços selecione Servidores de Aplicação, conforme segue abaixo:


  3. Clique em Novo:



  4. Preencha o cadastro com as informações da visão desejada e no campo Número máximo de registros, informe o novo valor máximo de registros que serão exibidos:



    Observação: Para identificar o ID do Server correspondente ao cadastro que deseja exibir mais registros, acesse o menu correspondente a ele e pressione: Ctrl + Alt + F9, conforme exemplo no print abaixo:




  5. Em nosso exemplo foi criado o Servidor de Aplicação para a tela de lançamentos (Gestão Financeira) aumentando a quantidade de registros na visão:



    Importante:
    O número máximo de registros deve ser avaliado com cautela, levando em consideração a real necessidade para que não impacte na performance do sistema.
     

  6. Após salvar o registro, ao acessar a tela de lançamentos novamente, a mensagem não é mais exibida:



Saiba mais
Para mais informações, consulte o link Criação de Servidor de Aplicação

Esse artigo foi útil?
Usuários que acharam isso útil: 4 de 5

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _