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Cross Segmentos - Backoffice RM - BI - Aplicativo não encontrado Relatório Delphi ambiente Smart Client

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao gerar um relatório Delphi via Nova MDI é apresentada a mensagem Aplicativo não encontrado

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - A partir da 12.1

Causa
Esse incidente ocorre, pois ao gerar um relatório Delphi via Nova MDI no menu Gestão\Gerador de relatórios\Visão.NET é necessário associar a extensão .REL para ser aberta no sistema operacional sempre com o mesmo aplicativo(RMRelviewer).

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Extraia o arquivo RMRelViewer.zip que encontra - se em anexo neste artigo e adicione no diretório de instalação do Smart Client, geralmente é C:\TOTVS:
  2. Utilize o arquivo Teste.REL que segue em anexo, e aplique o procedimento do print abaixo:
               image2013-6-19_9_41_50.png
  3. Após associar a extensão, gere o Relatório Delphi na nova MDI normalmente.
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1 Comentários

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    Alexandro do Nascimento (Editado )

    O procedimento repassado não é efetivo. Observamos que durante a instalação, o RM por padrão atribui o caminho do executável dos relatórios (.rel) como: C:\TOTVS\CorporeRM\RMRelViewer, pelo menos nas versões 12.1.23 e 12.1.24. Enquanto toda nossa instalação foi realizada no disco D:\TOTVS\... , portanto, para resolver criamos o diretório C:\TOTVS\CorporeRM\RMRelViewer e copiamos o  RM_REL_Viewer.exe para este diretório, o que resolveu efetivamente o problema, dispensando a execução dos passos 2.

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