Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Logix - NFE - Mensagem ao imprimir o DANFE Houve um erro na geração do arquivo PDF

Ocorrência 
Mensagem ao imprimir o DANFE - Documento Auxiliar da Nota Fiscal Eletrônica: Houve um erro na geração do arquivo PDF - Portable Document Format.

Ambiente

Cross Segmentos - TOTVS Backoffice (Linha Logix) - Nota Fiscal Eletrônica (NFE) - Versão 12.

Causa

Problemas de permissão do sistema de arquivos ou parametrização errada.

Solução
É necessário avaliar a ocorrência do problema e seguir os passos:

Ocorre para somente uma nota?
1. No diretório do DANFE é gerado um arquivo *.txt - texto para a nota fiscal, abra o arquivo e verifique se existe alguma quebra de linha ou carácter especial. Geralmente a quebra de linha existe após a descrição de um item ou nas informações complementares da nota. Identificando a origem da quebra de linha ou carácter especial altere o cadastro no Logix e reimprima o DANFE.
2. Se o arquivo PDF já foi gerado uma vez - reimpressão, verificar se o usuário tem permissão para sobrescrever o arquivo no diretório do DANFE, caso não tenha basta excluir o PDF e arquivos txt gerados anteriormente. E para que não ocorra mais a situação é necessário alterar as permissões da pasta onde está sendo gerado o PDF.

Ocorre para todas as notas?
1. Verificar se o aplicativo Java está instalado no servidor de aplicação do Logix ou está desatualizado - versão inferior a 1.6.
2. Verificar se as bibliotecas Java: itext.jar, nfeletronica.jar e jdom.jar, estão salvas no diretório correto que está informado na variável CLASSPATH.
3. Verificar se não há mais de uma biblioteca itext salva no diretório informado na CLASSPATH, caso exista mais de uma, mantenha apenas a última versão e exclua as demais.
4. O caminho informado no VDP10076 - Configuração documentos eletrônicos para salvar o DANFE deve possuir uma barra no final do diretório \ ou /, exemplo: /totvs/nfe/danfe/.
5. Verificar também o parâmetro: LOG00086 - Administração Parâmetros em Processo Saídas / Faturamento / Nota Fiscal Eletrônica: Diretório para a geração dos arquivos temporários do Danfe - código: local_arq_temp_danfe.

Ocorre somente quando envia uma faixa de notas?
1. Verificar o parâmetro no LOG00086 em Processo Saídas / Faturamento / Nota Fiscal Eletrônica: Enviar um unico arquivo com todas as Danfes para a impressora? - código: enviar_todas_danfes.
Se estiver informado como S-Sim é necessário ter a biblioteca Java Multivalent.jar informada na CLASSPATH, junto com as demais bibliotecas: nfeletronica.jar, etc.
Caso não seja de interesse gerar todos os DANFEs de uma faixa num mesmo arquivo, é preciso informar este parâmetro como N-Não.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _