FAQs - Suporte técnico

RM - Integrações - Metadados - Erro após atualizar versão

Ocorrência 
Apresenta erro ao abrir metadados após atualizar versão do RM.
'Ocorreu um erro ao efetuar a leitura da visão:
Método não encontrado: 'RM.Lib.Data.DbServices RM.Lib.Server.RMSServer.get_DBS()'.'
Erro_Metadado.png

Causa
Quando é gerado um projeto de Metadados ele compila as dll's utilizando a versão da biblioteca instalada em seu ambiente, sendo assim quando se faz uma atualização de release ( Ex: 12.1.17 para 12.1.18), as dll's ficam desatualizadas.

Ambiente
Todas as versões do RM onde possui a ferramenta Metadados.

Solução
 - Acesse a pasta onde está instalado seu RM (Padrão: “C:\CorporeRM\RM.Net”.)
- Localize o 'RM.Host.ServiceManager.exe'
 
Host.Net.png 
 
- Após abrir o programa, selecione a Opção 'Apagar _Broker.dat' 
- Clique em 'Parar' e aguarde o Status mudar para 'Parado'
 
ManagerService.png
ManagerService2.png

- Localize as DLLs do seu projeto na mesma pasta 
Exemplo: RM.MD.PRJ0000000.Cliente.dll e RM.MD.PRJ0000000.Server.dll (inclusive as temporárias se houver) e exclua.
 
DLLs.png

- Volte ao 'RM.Host.ServiceManager.exe'
- Clique em 'Iniciar', e aguarde o Status ficar como 'Iniciado'
- Abra o RM e gere o(s) projeto(s) novamente em Serviços Globais > Metadados > Projeto > Processos > Gerar Projeto de Metadados.
GerarProjeto.png
 
 
Importante: Em caso de ambiente N Camadas, ao parar o host o serviço dos demais ambientes também irão parar.

Acesse nossa Central de Atendimento na opção Perguntas Frequentes e verifique nossos Artigos para se Autoatender.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 2

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _