Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - Integração - Metadados - Erro após atualizar versão

time.pngTempo aproximado para leitura: 00:02:30 min

Ocorrência 
É apresentado erro ao abrir um Metadados após atualizar versão do RM.
'Ocorreu um erro ao efetuar a leitura da visão:

Método não encontrado: 'RM.Lib.Data.DbServices RM.Lib.Server.RMSServer.get_DBS()'.'
Erro_Metadado.png

Causa
Quando é gerado um projeto de Metadados ele compila as dll's utilizando a versão da biblioteca instalada em seu ambiente, sendo assim quando se faz uma atualização de release ( Ex: 12.1.2209 para 12.1.2302), as dll's ficam desatualizadas.

Ambiente
Cross Segmentos - Backoffice RM - Integrações - Todas as versões.

Solução
Para solucionar o comportamento, basta realizar o processo de recompilar as dll's de seu projeto, seguindo o artigo abaixo:
 
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 4

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _