Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmento - Backoffice Linha Protheus - SIGACTB - CTBA020 - Plano de contas: Error.log - Erro invalid macro source (SSYacc0105e: Error token failed, no valid token) no Plano de contas

Cross Segmento - Backoffice Linha Protheus - SIGACTB - CTBA020 - Plano de contas: Error.log - Erro invalid macro source (SSYacc0105e: Error token failed, no valid token) no Plano de contas

Ocorrência
Ao realizar a inclusão/alteração/exclusão de uma conta contábil é exibido o seguinte erro:

invalid macro source (SSYacc0105e: Error token failed, no valid token) :{|a,b,c| FWInitCpo(a,b,c),lRet:=(INCLUI .and. If(FunName()=="CTBA160",.T.,.F.)",.F.,.T.)),FWCloseCpo(a,b,c,lRet,.T.),lRet } on FWBUILDFEATURE(PROTHEUSFUNCTIONMVC.PRX) 05/10/2017 18:39:41 line : 5199


Ambiente:
Protheus – Contabilidade Gerencial – A partir da versão 12.1.17

Causa:
Erro ocorre, pois o "modo de edição" X3_WHEN do campo CTS_ORDEM esta com conteúdo:

INCLUI .and. If(FunName()=="CTBA160",.T.,.F.)",.F.,.T.)

Solução:

Para correção desta ocorrência deve ajustar o conteúdo do campo X3_WHEN referente ao campo CTS_ORDEM através do módulo configurador com a informação:

 

INCLUI .and. If(FunName() $ "CTBA160|CTBA161",.T.,.F.)

Esse artigo foi útil?
Usuários que acharam isso útil: 14 de 15

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _