Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Hotelaria - TOTVS Backoffice (Linha CMNET) - FF - Como instalar o WINMFD2, converter e importar o arquivo SINTEGRA para o FiscAll Flex

Hotelaria - TOTVS Backoffice (Linha CMNET) - FF - Como instalar o WINMFD2, converter e importar o arquivo SINTEGRA para o FiscAll Flex

Ocorrência

Não é possível converter o MFD para o arquivo Sintegra e é reportado diferenças no relatório de Cupom Fiscal x Redução Z 

Ambiente

TOTVS Hotelaria - TOTVS Backoffice (Linha CMNET) - Fiscal Flex - A partir da versão
06. 

Causas

  • Instalação do WINMFD2 incorreta.
  • DLLs da instalação não são as corretas.
  • Modelo da impressora está informado incorretamente no aplicativo WinMFD2.

Solução

1. A correta instalação do WinMFD2 é crucial para o perfeito funcionamento do software, para isso é necessário que ele possua as Dlls corretas. Estas Dlls encontram-se na pasta do executável, como mostra a imagem abaixo; 

 

1.JPG

 

2. O WinMFD2 para os modelos de ECF MP-2100 e MP-4000 precisam ser instalados como Administrador, clicando com o botão direito do mouse no instalador;

 

3.JPG

OBS: Não execute o programa ao final da instalação!!

3. Após concluir a instalação, copie todos os arquivos da pasta do instalador para a pasta onde foi instalada; 

mceclip0.png

4. Por padrão, a instalação é realizada neste caminho: ” C:\Program Files (x86)\Bematech\WinMFD2”;

mceclip1.png

5. Aparecendo a tela abaixo, clique em Substituir os arquivos no destino;

mceclip2.png

6. A instalação cria um atalho na área de trabalho com o seguinte ícone, basta apenas executá-lo;

 

2.JPG

 

7. Já o WinMFD2 da ECF MP-4200 é portátil, ou seja, não precisa realizar o mesmo procedimento do modelo MP-2100, basta apenas acessar a pasta e clicar com o botão direito em cima do executável, também executando como Administrador;

 

4.jpg

 

OBS: Os próximos passos são os mesmos para todos os modelos de ECF.
8. Com o WinMFD2 aberto, clique na aba Comunicação e selecione a porta e modelo da Impressora.
Caso tenha dúvidas para buscar estas informações, consulte seu departamento de TI.

 

5.jpg

 

9. Em seguida clique na opção Leitura X pela Serial, esta opção fará uma leitura na ECF para identificar se ela encontra-se corretamente instalada e parametrizada. Caso esteja mostrará uma tela com suas informações, caso contrário não mostrará nenhuma informação. Então será necessário rever as parametrizações de porta, modelo e a correta instalação;

 

7.jpg

 

10. Em seguida clique nas opções Download Memória de Fita-Detalhe. Esta fará o download do arquivo MFD contendo as informações dos cupons e reduções Z do período selecionado.

 

6.jpg

 

8.jpg

 

11. Com o MFD extraído, será necessário convertê-lo para o arquivo Sintegra.
12. Acesse o caminho abaixo e busque pelo MFD extraído anteriormente. Selecione também o destino onde será salvo o arquivo sintegra, o mês, ano e insira qualquer número no campo N°. As demais informações não são necessárias, mas se desejar pode preenchê-las.

13. Para confirmar clique em Gerar Registros.

 

9.jpg

 

10.jpg

 

14. Com o arquivo sintegra criado, feche o WinMFD2 e abra o FiscAll Flex. Caso já tenha uma importação do mesmo período, será necessário excluí-la, caso contrário, pode pular esta etapa.

15. Acesse a aba Sistema, opções Utilitários e Deletar Movimentações geradas pelo Fiscall Flex.

 

11.jpg

 

16. Na janela que se abriu selecione as datas inicial e final, o Equipamento ECF e desmarque apenas a última opção.

 

12.jpg

 

Este processo pode demorar um pouco dependendo do movimento do período, então aguarde até o fim.

17. A próxima etapa é a integração do arquivo sintegra, acesse o caminho abaixo para realizar a importação.

 

13.jpg

 

18. Na janela que se abriu desmarque a flag destacada e busque pelo arquivo sintegra convertido no WINMFD2 clicando no ícone da lupa.

 

14.jpg

 

19. Após selecionar o arquivo ele mostrará o movimento de redução Z e dos cupons de cada dia na lateral esquerda. Caso apareça o aviso abaixo, será necessário acessar o módulo PDV Configuração e acessar o utilitário Integrar Somente Itens de Venda com FiscAll Flex.
Nele é possível selecionar um ponto de venda ou todos ao mesmo tempo.
Caso a importação não resolva, será necessário cadastrar os itens manualmente no FiscAll Flex. 

 

15.jpg

 

 

 

Após inserir os itens do aviso, o arquivo carregará sem problemas. 
20. Para confirmar a importação clique no botão Importar Registros Selecionados.

 

16.jpg

 

Este processo também pode demorar dependendo do movimento do período, então aguarde até o término.

21. Por fim confirme no Relatório de Cupom Fiscal x Redução Z se a ECF importada possui diferenças no período. Caso tenha refaça todo procedimento.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _