Ocorrência
Não é possível converter o MFD para o arquivo Sintegra e é reportado diferenças no relatório de Cupom Fiscal x Redução Z
Ambiente
TOTVS Hotelaria - TOTVS Backoffice (Linha CMNET) - Fiscal Flex - A partir da versão
06.
Causas
- Instalação do WINMFD2 incorreta.
- DLLs da instalação não são as corretas.
- Modelo da impressora está informado incorretamente no aplicativo WinMFD2.
Solução
1. A correta instalação do WinMFD2 é crucial para o perfeito funcionamento do software, para isso é necessário que ele possua as Dlls corretas. Estas Dlls encontram-se na pasta do executável, como mostra a imagem abaixo;
2. O WinMFD2 para os modelos de ECF MP-2100 e MP-4000 precisam ser instalados como Administrador, clicando com o botão direito do mouse no instalador;
OBS: Não execute o programa ao final da instalação!!
3. Após concluir a instalação, copie todos os arquivos da pasta do instalador para a pasta onde foi instalada;
4. Por padrão, a instalação é realizada neste caminho: ” C:\Program Files (x86)\Bematech\WinMFD2”;
5. Aparecendo a tela abaixo, clique em Substituir os arquivos no destino;
6. A instalação cria um atalho na área de trabalho com o seguinte ícone, basta apenas executá-lo;
7. Já o WinMFD2 da ECF MP-4200 é portátil, ou seja, não precisa realizar o mesmo procedimento do modelo MP-2100, basta apenas acessar a pasta e clicar com o botão direito em cima do executável, também executando como Administrador;
OBS: Os próximos passos são os mesmos para todos os modelos de ECF.
8. Com o WinMFD2 aberto, clique na aba Comunicação e selecione a porta e modelo da Impressora.
Caso tenha dúvidas para buscar estas informações, consulte seu departamento de TI.
9. Em seguida clique na opção Leitura X pela Serial, esta opção fará uma leitura na ECF para identificar se ela encontra-se corretamente instalada e parametrizada. Caso esteja mostrará uma tela com suas informações, caso contrário não mostrará nenhuma informação. Então será necessário rever as parametrizações de porta, modelo e a correta instalação;
10. Em seguida clique nas opções Download Memória de Fita-Detalhe. Esta fará o download do arquivo MFD contendo as informações dos cupons e reduções Z do período selecionado.
11. Com o MFD extraído, será necessário convertê-lo para o arquivo Sintegra.
12. Acesse o caminho abaixo e busque pelo MFD extraído anteriormente. Selecione também o destino onde será salvo o arquivo sintegra, o mês, ano e insira qualquer número no campo N°. As demais informações não são necessárias, mas se desejar pode preenchê-las.
13. Para confirmar clique em Gerar Registros.
14. Com o arquivo sintegra criado, feche o WinMFD2 e abra o FiscAll Flex. Caso já tenha uma importação do mesmo período, será necessário excluí-la, caso contrário, pode pular esta etapa.
15. Acesse a aba Sistema, opções Utilitários e Deletar Movimentações geradas pelo Fiscall Flex.
16. Na janela que se abriu selecione as datas inicial e final, o Equipamento ECF e desmarque apenas a última opção.
Este processo pode demorar um pouco dependendo do movimento do período, então aguarde até o fim.
17. A próxima etapa é a integração do arquivo sintegra, acesse o caminho abaixo para realizar a importação.
18. Na janela que se abriu desmarque a flag destacada e busque pelo arquivo sintegra convertido no WINMFD2 clicando no ícone da lupa.
19. Após selecionar o arquivo ele mostrará o movimento de redução Z e dos cupons de cada dia na lateral esquerda. Caso apareça o aviso abaixo, será necessário acessar o módulo PDV Configuração e acessar o utilitário Integrar Somente Itens de Venda com FiscAll Flex.
Nele é possível selecionar um ponto de venda ou todos ao mesmo tempo.
Caso a importação não resolva, será necessário cadastrar os itens manualmente no FiscAll Flex.
Após inserir os itens do aviso, o arquivo carregará sem problemas.
20. Para confirmar a importação clique no botão Importar Registros Selecionados.
Este processo também pode demorar dependendo do movimento do período, então aguarde até o término.
21. Por fim confirme no Relatório de Cupom Fiscal x Redução Z se a ECF importada possui diferenças no período. Caso tenha refaça todo procedimento.
0 Comentários