Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-FAT-Erro invalid field name in Alias TMP1->CK_PROJPMS on A415LINOK


Ocorrência

Erro na tela de orçamento: invalid field name in Alias TMP1->CK_PROJPMS on A415LINOK(MATA415.PRX)

Causa

O erro ocorre quando há integração com o projeto do módulo PMS, onde há necessidade de informar o campo CK_PROJPMS, pode ser que o campo não exista no ambiente ou não esteja em uso .

Ambiente

Microsiga Protheus - versão 11 e versão 12

Solução
 
Avalie se o campo CK_PROJPMS está como usado no dicionário de dados, via configurador, pois o erro somente ocorre se o mesmo estiver com o uso desmarcado.
Para ajustar:
1-Edite a tabela SCK;
2-Edite o campo CK_PROJPMS;
3-Marque-o como usado;
4-Salve a tabela;
5-Atualize o dicionário de dados;
6-Reinicie o sistema e refaça o processo,  o erro deixará de ocorrer.
 
Obs: Tivemos clientes que apresentou o mesmo problema com os campos CK_EDTPMS e CK_TASKPMS, neste caso, faça o mesmo processo utilizado para o campo CK_PROJPMS, que o erro deixará de ocorrer.
 
Outro impeditivo é se o nível desses campos (CK_PROJPMS, CK_EDTPMS e CK_TASKPMS) forem alterados, também ocorre o erro, por padrão mantenha como nível 1.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

2 Comentários

  • Avatar
    Aurelio Duarte

    Apos a alteração no campo o sistema apresentou mais dois campos para a mesma solução!

    • CK_EDTPMS
    • CK_TASKPMS

    Após alteração a função salvar passou a funcionar!

     

    Obrigado!

    0
    Ações de comentário Permalink
  • Avatar
    FERNANDA APARECIDA DA SILVA SANTOS

    Obrigada pelo retorno Aurélio, estarei complementando o artigo para que outros clientes, tenham o problema já saibam o que precisam fazer para corrigir.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _