Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - Erro de comunicação com a impressora fiscal Bematech

Ocorrência
Nos módulos SIGALOJA/SIGAFRT/TOTVS PDV, ocorre erro de comunicação com a impressora fiscal Bematech
 
Causa
Impressora não comunica com o sistema.

Ambiente
Microsiga Protheus - SIGALOJA/SIGAFRT/TOTVS PDV - Aplicável a partir da versão 11.80

Solução
Para realizar comunicação com a Impressora Fiscal Bematech, revise os passos abaixo:

1 - Verificar se as DLL´s do Fabricante estão na pasta do Smartclient (Local).
 
2 - Em ambiente atualizado não é mais necessário inserir as DLL´s do Fabricante nas pastas System32 (Windows 32Bits) ou SysWow64 (Windows 64Bits), neste caso é necessário remover para evitar conflitos de DLL´s.
 
3 - Configurar o arquivo Bemafi32.ini, sessão ProtocoloUnico de acordo com as informações abaixo.
Impressoras do convênio 85/01 a tag ProtocoloUnico deve ser = 0
Impressoras do convênio 09/09 a tag ProtocoloUnico deve ser = 1 ( ECF Blindado)

Observação: Para o modelo de ECF Blindado o campo PDV do cadastro de estacão deve ser preenchido com 3 dígitos.

Se após revisar os dados acima a impressora não realizar a comunicação, habilite o Log do link abaixo e verifique se é apresentando alguma falha na impressora fiscal, segue exemplo.
 
 
Bematech / Daruma / Sweda
<- Status Bematech: ACK:6, ST1:0, ST2:1, ST3:143 DADOS DA ÚLTIMA RZ CORROMPIDO
Neste caso é necessário retirar uma reduçãoZ, para verificar se a impressora retorna ao seu status padrão e realizar a comunicação com o Sistema.
 
Caso esteja utilizando o emulador de impressora o mesmo não funciona com as DLL's da Bematech atual.

Acesse nossa Central de Atendimento na opção Perguntas Frequentes e verifique nossos Artigos.

 
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _