FAQs - Suporte técnico

RM - MOV - Chave Duplicada FXLANOLDPRIM

Ocorrência
Ao salvar movimento com integração de lançamento financeiro, o Sistema acusa a mensagem de violação abaixo:

Ambiente
RM - Gestão de Estoque Compras e Faturamento - Todas as Versões

Causa 
A inconsistência existe devido a parametrização utilizada na coligada em relação a numeração de movimento e numeração do lançamento financeiro.

Solução
Para corrigir o problema de violação da chave FXLANOLDPRIM, veja o exemplo abaixo para melhor entendimento de como o sistema se comporta:

  1. A máscara do movimento possui 8 dígitos 
  2. O tipo de documento gera sequencial de letras (AA - ZZ) usando 2 casas para isso (+ o separador)
  3. O tamanho do Documento do financeiro possui 8 dígitos
  4. Numero do Movimento = 01234567
  5. Condição de pagamento = 30+60 Dias (Duas parcelas)

Ao salvar o movimento será feito:

  • Lançamento 1 = 01234567 -> Faltam dois dígitos do sequencial + o separador (/AA) pois o correto seria 01234567/AA mas como não tem espaço suficiente no tamanho do documento do financeiro ele trunca e "Salva" (em memória) o lançamento financeiro a numeração truncada
  • Lançamento 2 = 01234567 -> Faltam dois dígitos do sequencial + o separador (/AB) pois o correto seria 01234567/AB mas como não tem espaço suficiente no tamanho do documento do financeiro ele trunca. Contudo, ao tenta "Salvar" o segundo lançamento ocorre a violação da chave FXLANOLDPRIN, pois ele tem a mesma numeração da parcela anterior.

Neste caso, será necessário alterar o tamanho do documento nos parâmetros. Acesse o menu Ambiente | Parâmetros | Gestão de Estoque, Compras e Faturamento | Integrações | Financeira | Contas a pagar | Inclusão | "Tamanho do Número".

Obs.:O valor deverá ser o somatório da quantidade de dígitos do movimento (Mascara do movimento) mais a quantidade de dígitos do sequencial (2) mais a quantidade de dígitos do separador(1). Portando, para este exemplo, marcado este campo (Tamanho do Número) para 11 (8 da numeração do movimento + 2 do Sequencial + 1 do separador) e salvo o movimento irá funcionar.

Importante
Se a condição de pagamento for "A vista", pode ser que a inconsistência não ocorra, pois a numeração será gerada apenas uma vez, sem os sequenciais e não haverá um "segundo" lançamento para duplicar a base, mas ainda assim pode ser que o problema ocorra caso a própria numeração do movimento seja truncada devido ao seu tamanho.
Caso este documento não funcione, então deverá ser verificado o link : DICAS - FXLANOLDPRIM

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados.

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _