Ocorrência
No Módulo Varejo do Produto Virtual Age, ao abrir componente de venda PDVFM001/ TRAFM080 identifica-se transação de TEF pendente, o gerenciador do TEF emitirá uma mensagem "O sistema de automação está tentando anular a transação ... aprovada pela operadora.... Deseja confirmar ou anular a transação?", esta pendencia impede a continuidade da transação de venda atual ou de uma nova venda.
Ambiente
Virtual Age - Varejo
Causa
A transação de TEF fica pendente por segurança do próprio sistema de TEF e do cliente final, para que o usuário de caixa proceda de forma correta com a operação de recebimento do cartão quando algo inesperado acontece. Segue principal causa para existir transação de TEF pendente no TEF (Pay&Go/Sitef/Rede) e no sistema:
Solução
Passo 1: Acesse o componente TEFFP001;
Passo 2: No campo Situação selecione a opção Transação autorizada sem cupom impresso ou Transação confirmada sem cupom impresso
2.1: Pressione F4 para listar as transações TEF decorrentes do dia;
2.2: Selecione a transação que estiver com a situação Transação autorizada sem cupom impresso ou Transação confirmada sem cupom impresso;
2.3: No campo Situação altere a situação para Não foi possível imprimir cupom ou Transação confirmada sem cupom impresso;
2.4: Clique no botão Alterar Situação;
Observações
5. Para conseguir efetuar a alteração da situação no TEF, é necessário que o usuário tenha a restrição IN_LIBERA_ALTSIT dentro do TEFFP001, botão Ajuda liberada na empresa logada.
Se você for usuário e não tiver permissão de alteração entre em contato com seu TI ou usuário Administrador.
6. Se desejar a reimpressão do comprovante do cartão, consulte este artigo:
Reimpressão do Comprovante de TEF
0 Comentários