Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAFAT - Incorrect_syntax_near


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência 

Ao efetuar a contabilização, gera o erro: 
: Error : 102 (37000) (RC=-1) - [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near "X"

Causa

O erro ocorre por que ao tentar executar uma query do lançamento padrão para a contabilização, o Banco de Dados está recebendo conteúdo de gravação com caractere especial (' " # @ $ % ¨! & *).

Exemplo:

Erro : 102 (37000) (RC=-1) - [Microsoft][ODBC SQL Server Driver][SQL Server]Incorrect syntax near ''E"

Veja a definição da Query do histórico aglutinado do lançamento padrão: 

CT5_HAGLUT(C) :VENDAS NF."+SD2->D2_SERIE+"/"+SD2->D2_DOC+"-"+SUBSTR(SA1->A1_NOME,1,15),1,40)      

Resultado recebido no arquivo de contra prova, tabela CTK :  'VENDAS NF 001 000101 - 000008572-ABCIN ' E LTDA'

O apostrofo entre a letra N e a letra E , é um caractere especial não aceito na montagem da query para o banco dados.

Neste caso, a  informação do nome do cliente no cadastro , por exemplo, possui um apostrofo ( ' ) na sua composição, isso interfere na codificação e gravação de banco de dados, onde ele entende que a query finalizou seu bloco de instruções quando encontra o apostrofo, o que vier após isso, fica caracterizado como erro de sintaxe.


Ambiente

Cross Segmentos- TOTVS Backoffice (Linha Protheus)-SIGAFAT- todas as versões

Solução

Para solucionar:
1-Identifique o campo que está trazendo o caractere especial.

2-Retire o caractere especial da informação, assim não terá problemas para a gravação no Banco de Dados.

3- Em último caso, utilizar um execblock no lançamento padrão, para poder tratar caracteres especiais. Em caso de dúvidas sobre esse processo, contate nossa equipe de atendimento Advpl para melhor orientação.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _