Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS Backoffice Linha Protheus - ADVPL - Mensagem ao tentar debugar customização no TDS ( Error loading debug thread )

Cross Segmentos - TOTVS Backoffice Linha Protheus - ADVPL - Mensagem ao tentar debugar customização no TDS ( Error loading debug thread )

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao tentar entrar em modo debug para depurar rotinas customizadas (especificas) é exibida a mensagem: "Error loading debug Thread"

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.80

Causa
A Causa desta mensagem é o fato do cliente estar usando balanceamento de carga e Debugando no Servidor Master.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

No arquivo totvssmartclient.ini, acrescente mais uma seção TCP
Ex: 

[TCP DEBUG]
Server= (IP Slave)
PORT= (Porta Slave)

Tanto o IP quando a porta devem apontar para um servidor e uma porta de um servidor Slave
Exemplo completo:

totvssmartclient.ini:

[config]
lastmainprog=sigamdi
envserver=dbprod

[drivers]
active=tcp

[tcp]
server=10.1.1.8
port=1811

[tcp_debug]
server=10.1.1.7 -> Seção criada
port=8026

totvsappserver.ini: (Master)

[ServerNetwork]
Servers=operandi2s0,operandi2s1,operandi1s2,operandi1s3
MasterConnection=0

[operandi2s0]
TYPE=TCPIP
Server=10.1.1.8
Port=8024
Connections=30

[operandi2s1]
TYPE=TCPIP
Server=10.1.1.8
Port=8025
Connections=40

[operandi1s2]
TYPE=TCPIP
Server=10.1.1.7 -> Referência usada para criar a Seção no totvssmartclient 
Port=8026
Connections=40

[operandi1s3]
TYPE=TCPIP
Server=10.1.1.7
Port=8027
Connections=40

 

Observações:

  • Para apoio e maiores informações referente a configurações sobre o Balanceamento de Cargas consulte o link:
  • Balanceamento de carga entre serviços (Load Balance)
  • Lembrando que para essa necessidade é imprescindível que se tenha conhecimento na configuração dos ambiente e do App.ini, pois para que não seja gerado erro no processo verificar se os ambientes estão de acordo e estejam apontado para o slave e não para o master .
  • Caso a inconsistência permaneça, consulte o seu arquivo appserver.ini e verifique se o servidor Master está comentado, caso não esteja, comente-o, pois é necessário que o apontamento para os slaves ocorra tanto no TDS quando no AppServer.

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _