Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATR900 - type mismatch on compare on REPORTPRINT(MATR900.PRX)


time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência
Ao tentar emitir o relatório KARDEX POR PERÍODO (MATR900) apresenta o error.log "type mismatch on compare on REPORTPRINT(MATR900.PRX) 20/09/2021 10:12:24 line : 349" como corrigi-lo?.

 

type mismatch on compare on REPORTPRINT(MATR900.PRX) 20/09/2021 10:12:24 line : 349

[TOTVS build: 7.00.210324P-20211006]
Called from {|OREPORT| REPORTPRINT(OREPORT)}(MATR900.PRX) 20/09/2021 10:12:24 line : 99
Called from {|| IIF(SELF:INIT(),(LACTION := EVAL(SELF:BACTION,SELF),SELF:FINISH()),LOK:= .F. ),LEND := .T. ,ODLG:END()}(REPORT01.PRW) 12/11/2021 14:43:23 line : 2184
Called from ::MSDIALOG:ACTIVATE
Called from TREPORT:PRINT(REPORT01.PRW) 12/11/2021 14:43:23 line : 2197
Called from TREPORT:PRINTDIALOG(REPORT01.PRW) 12/11/2021 14:43:23 line : 3442
Called from MATR900(MATR900.PRX) 20/09/2021 10:12:24 line : 20
Called from __EXECUTE(APLIB090.PRW) 12/11/2021 14:43:23 line : 721
Called from FWPREEXECUTE(FWPREEXECUTE.PRW) 12/11/2021 14:43:29 line : 86
Called from {|| FWPreExecute('Por Período', 'MATR900()', 1, '04', 'xxxxxxxxxx') }(FWUIMENUL.PRW) 12/11/2021 14:43:29 line : 197
Called from ::TWINDOW:ACTIVATE
Called from MSAPP:ACTIVATE(FWAPP.PRW) 12/11/2021 14:43:28 line : 755
Called from SIGAADV(APLIB000.PRW) 12/11/2021 14:43:23 line : 71


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.


Causa
Esse incidente geralmente ocorre, devido ausência da pergunta 17 do parâmetro, veja abaixo com corrigir.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Verificando no fonte do MATR900 na linha 349 exibe a necessidade da pergunta para impressão do relatório;

mceclip0.png

 

2. Acessar o módulo Configurador em Base de Dados / Dicionário / Base de Dados e posicionar em Perguntas e pesquisar pelo grupo de perguntas MTR900;

mceclip1.png

 

3. Editar o grupo de Perguntas para inclusçao da Pergunta 17

mceclip2.png

2. Incluir uma linha a mais com os conteúdos como do print abaixo:

mceclip3.png

Após esse procedimento não exibirá amis o error.log

 

Saiba Mais:
Clique aqui e veja mais artigos sobre Movimentações no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _