Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Varejo Lojas - Linha Protheus - PDV - RPS - Error Log na Impressão comprovante TEF com PAF-ECF

Ocorrência
No TOTVS PDV, em ambiente configurado com PAF-ECF, Impressora Fiscal BEMATECH MOD: MP-4200 TH FI II, ao importar orçamento contendo somente item de serviço para finalização de RPS e o pagamento for utilizando TEF, o sistema apresenta o seguinte error.log ao tentar imprimir os comprovantes:

variable is not an object on STWPRINTCOMP(STWPAYCARD.PRW) 02/09/2022 14:50:36 line : 270

Ambiente
TOTVS Varejo Lojas - Linha Protheus - PDV - a partir da versão 12.1.33

Causa
Este erro ocorre devido configuração incorreta no arquivo SIGALOJA.ini, localizado na pasta smartclient.

Solução
Configurar a sessão [Microsiga] no arquivo SIGALOJA.ini informando o índice do totalizador em vez de utilizar a descrição.

Exemplo de Leitura X:

mceclip0.png

Exemplo de configuração incorreta:

[Microsiga]
Pedido=RECEBIMENTO
TefPedido=RECEBIMENTO
IndTotPed=03

 

Exemplo de configuração correta:

[Microsiga]
Pedido=03
TefPedido=03
IndTotPed=03

 

Importante: Para que esta operação funcione corretamente também para operação de cartão de crédido/débito não TEF, o arquivo BEMAFI32.ini deve ser configurado com a sessão [Microsiga] da seguinte forma, seguindo a mesma leitura X como base:

[Microsiga]
Pedido=RECEBIMENTO
TefPedido=RECEBIMENTO
IndTotPed=03

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _