Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - PIMS CS - PIMSSERVER - Ajuste de Formatação de Datas no Banco Oracle para Evitar Falhas de Seleção no PIMSSERVER

time.png Tempo aproximado para leitura: 00:02:20 min

Ocorrência
Utilizando o PIMSServer Modernizado Versão 12.1.2209 ou Superior, poderá ocorrer a mensagem de erro: java.sql.SQLException: DAO Runtime Select Exception: ORA-01843: not a valid month, essa mensagem de erro poderá surgir em diversos módulos do PIMS CS que utilizem essa versão do PIMSServer.

Ambiente
TOTVS Agro - TOTVS Agro - Bioenergia - Interface Externas - PIMSSERVER - Versão 12

Causa 
Esse incidente ocorre devido a falta de dois argumentos dentro do arquivo service.bat existente no módulo que está em utilização no PIMS CS, do qual foram instalados no momento da instalação do TOTVS Agro PIMS Server, localizado no seguinte diretório: Totvs/.../Módulo/tomee/bin.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Pare o serviço do PIMSServer respectivo ao módulo em utilização;

2. Abra o arquivo service.bat localizado em Totvs/.../Módulo em utilização/tomee/bin com um editor de texto, exemplo Notepad++;

3. Verifique na linha 253 ou na linha que contenha este conteúdo abaixo e inclua os argumentos do passo 4:

DAO.png

4. Insira os dois argumentos a seguir, mantenha as aspas duplas, conforme imagem:
-Duser.language=pt;-Duser.country=BR;

DAO1.png

5. Abra o Prompt de Comando - CMD como Administrador;

DAO2.png
 

6. Passe o caminho onde está localizado a pasta tome\bin do módulo em utilização que ocorreu o erro no PIMS CS, é obrigatório que a ultima pasta do caminho seja a bin. Exemplo abaixo:

DAO3.png

7. Execute o comando abaixo clicando Enter;
Service Remove:

DAO4.png

8. Execute o comando abaixo clicando Enter;
Service Install:

DAO5.png

9. Feche o CMD;
 

10. Suba o serviço do PIMSServer 12.1.2209 respectivo ao módulo em utilização;

11. Valide novamente o processo/atividade que ocorreu a mensagem de erro no PIMS CS.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _