FAQs - Suporte técnico

Varejo - Moda - Integração - Mensagem de erro na integração de pessoa com o Totvs Conector: Erro: ORA-02291: restricao de integridade (PES_CLIENTE_PED_PEDIDOC) violada - chave mae nao localizada



time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Ao fazer a integração entre Totvs Conector - Vtex e o Totvs Moda é apresentada a mensagem de erro:

Erro: ORA-02291: restricao de integridade (PES_CLIENTE_PED_PEDIDOC) violada - chave mae nao localizada; Metodo: TcConexao; dsKey:


Ambiente
TOTVS Varejo - TOTVS Moda - Faturamento

Causa
Esse incidente ocorre, pois a parametrização do sistema está incorreta dentro do cadastro de Pessoa, ocorre quando esse cadastro não está como Cliente.
mceclip0.png

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Validar na requisição qual o código da pessoa que está buscando para integração, esse dado fica no campo CD_CLIENTE;
mceclip1.png
2. Buscar no PESFM010 esse código para validar o cadastro da pessoa;
3. Marcar a opção de CLIENTE conforme FAQ: VA - FAT - Cliente Não Cadastrado
4. Enviar novamente a requisição para o Moda.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _