Tempo aproximado para leitura: 00:03:00 min
Ocorrência
Ao alterar o preço de um produto Avô, o preço não é replicado para os demais da família, conforme demonstro nas Figuras 01,02 e 03.
Figura 01 - Alterando o preço do Nível 2 no produto Avô 409111-6 e Confirmando atualização dos Filhos
Figura 02 - Confirmando atualização dos Produtos Filhos Fora de Linha
Figura 03 - Consultando o produto Filho (Pai) que não alterou o preço
Ambiente
Retail Manager System - Todas as versões
Causa
Esse problema ocorre devido aos produtos da família não estarem vinculados ao produto Avô.
Para identificar se os produtos estão vinculados, basta rodar a consulta abaixo que está anexada nesta documentação. Na imagem da Figura 04, demonstro que o resultado da consulta não houve retorno dos produtos da Família que deveriam estar vinculados ao produto Avô.
Figura 04 - Produto Avô (409111-6) sem o vínculo dos Filhos
Solução
Para resolver esse problema basta abrir o programa VABGHELI e Gerar o Help de Item que o sistema realizará a Sincronização das Tabelas de Help de Produtos com o Cadastro de Produtos, sendo assim fará o vínculo de todos os produtos do RMS que estão com problemas no Cadastro, conforme demonstro na Figura 05.

Figura 05 - Programa VABGHELI
Ao verificar novamente a consulta no banco é possível visualizar que o vínculo dos produtos foram criados com sucesso, conforme Figura 06.
Ao realizar uma nova tentativa de alteração de preço na transação 19, os produtos vinculados ao Avô serão alterados com sucesso!
Figura 06 - Consulta no banco de dados exibindo que os produtos foram vinculados ao produto Avô
0 Comentários