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Dúvida
No cadastro de Portos/Aeroportos, é possível realizar a alteração do campo "PAÍS" quando o mesmo é estrangeiro (EX), pois o mesmo apresenta com o campo Y9_PAIS bloqueado? Sendo possível em casos nacionais.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – Easy Export Control – Todas versões
Causa
Informado a necessidade no EEC, no cadastro de Portos/Aeroportos de alteração do campo "PAÍS" quando o mesmo é estrangeiro (EX) não é possível alterá-lo, sendo possível somente em casos nacionais.
Solução
O cadastro de Portos/Aeroportos não possui tratamento específico para país estrangeiro. O que ocorre, é que quando o cadastro já está em uso, como por exemplo quando o cadastro do Porto/Aeroporto está em uso em uma Via de Transporte, o sistema não permite mais que as informações sejam alteradas. Este tratamento é válido tanto para qualquer tipo de país. Isto é válido para Portos/Aeroportos cadastrados tanto como Origem como Destino.
Caso seja possível excluir a origem e destino da via de transporte (caso não tenha sido utilizada), o sistema passará a permitir a alteração do País.
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