Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Sistema não permite habilitar campo RC1_COMPET para edição no browser na inclusão manual de títulos

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Precisamos que o campo RC1_COMPET seja apresentado na rotina para o usuário preencher quando for inclusão manual de títulos

Ambiente
TOTVS RH - TOTVS RH (linha Protheus) - Gestão de Pessoal - Todas as Versões

Causa
O Sistema não permite que este campo seja habilitado para edição no browser, pois dentro do fonte ele já recebe uma atribuição de valor.

Solução

O valor gravado na emissão é definido no grupo de perguntas da rotina de geração de títulos:

RC1->RC1_COMPET   := cCompetTit
cCompetTit  := mv_par12

mceclip4.png

mceclip3.png

O campo competência também segue a mesma linha de raciocínio, sendo tratada no momento da geração através do campo competência:
mceclip5.png

 

Para criação de títulos sem a utilização dos filtros, seria necessário customizar a rotina, por exemplo, criando campos e utilizando os pontos de entrada disponíveis na rotina GPEM670 para preenchimento:
MP - GPE - Quais os pontos de entrada disponíveis na rotina GPEM670


Saiba Mais:

Artigos sobre Integração de Títulos

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _