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Ocorrência
Ao realizar a exportação de cadastro (VGPGPDVE) a carga não está chegando no PDV deixando a tabela AG1PDVPD cheia. Como resolver?
Ambiente
Retail Manager System - Todas as versões.
Causa
Esse incidente ocorre devido a algum problema na integração, que neste caso existia um erro no cadastro de um determinado item, que na sua descrição possuía caractere especial.
Metodo: EnviarZanthusProdutoParaInserirAlterar RefMSG: ERRO *** DescMSG: Server returned an invalid SOAP Fault. Please see InnerException for more details.
Toda integração com a Zanthus quando ocorre sem erros, a tabela AG1PDVPD é apagada após os dados serem sincronizados no frente de caixa. Sendo assim se a tabela ficou cheia, significa que existe algum problema na chegada das informações no PDV.
Solução
Quando falamos de integração RMS x Zanthus, temos que saber qual método gerou o erro. Para realizar essa identificação, por padrão, o Webservice vai gerar um log com a descrição ERROS que é gerado por padrão no diretório da Figura 01. No seu conteúdo apontará qual método apresentou erro, qual pasta e descrição do log aquele erro vai estar escrito.
Figura 01 - Diretório de geração dos Logs.
Ao abrir o log de ERROS, é possível notar que o erro foi no arquivo 2091_1 (Vermelho), no Método: EnviarZanthusProdutoParaInserirAlterar (Azul), e a mensagem de erro DescMSG: Server returned an invalid SOAP Fault. Please see InnerException for more details (Preto), conforme demonstro na Figura 02.
Figura 02 - Conteúdo do log de ERROS.
Para identificar em qual pasta o arquivo 2091_1 foi gerado, basta digitar a sua numeração na pesquisa do Windows dentro da pasta de logs que ele identificará o arquivo para analise, conforme aponto na Figura 03.
Figura 03 - Identificação do arquivo de log.
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