Tempo aproximado para leitura: 00:01:15 min
Ocorrência
Ao tentar fazer um apontamento de tarefa no APP Minha Manutenção o Sistema gera um log de pendências apresentando a mensagem de erro 2554 - Turno inexistente.
Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Datasul) - Aplicativo Minha Manutenção - Versão 12
Causa
A mensagem ocorre pela falta do cadastro do turno em uma das rotinas que o APP realiza a busca.
Solução
No apontamento da tarefa pelo APP não está disponível o campo Turno, assim como consta no programa MI0308 - Apontamento Mão-de-Obra. Neste caso, o turno será atribuído automaticamente conforme descrito abaixo:
- O Sistema irá verificar se há cadastro de capacidade para o técnico utilizado no apontamento no programa PO0102 - Capacidade Técnico, com a data de efetivação menor ou igual a data do apontamento.
- Não encontrando nenhum registro, será realizada a busca do turno da especialidade no programa PO0100 - Capacidade Especialidade.
- Caso também não tenha nada cadastrado, o programa irá buscar o turno dos parâmetros do módulo, no programa MI0101 - Parâmetros Manutenção Industrial, Página 4, campo Turno Padrão.
Se não encontrar turno em nenhum dos cadastros acima, o turno ficará em branco e será gerado um registro no programa html.milog - Log de Pendências.
Saiba mais
Para verificar a regra da busca da especialidade, acesse o link: Manufatura - Linha Datasul - APP Minha Manutenção - Definição da especialidade do técnico para apontamento de mão de obra no aplicativo Minha Manutenção
0 Comentários