Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - REST - Error de WebService WSCERR048

time.png Tiempo aproximado de lectura: 00:05:00 min

Ocurrencia:

Al ejecutar un servicio web Protheus SOAP devuelve el error WSCERR048.

 

Ambiente
[FRAMEWORK - Framework (Línea Protheus) MI - REST - Todas las versiones 12

Causa
Esta ocurrencia se reproduce, cuando se utiliza un código fuente de WebServices Client, al procesar el paquete SOAP recibido como un retorno de la acción / método solicitado.

Solución

Al analizar el paquete SOAP devuelto por el servicio, para la potencia de los parámetros ADVPL, si el paquete devuelto contiene una excepción de tipo SOAP FAULT, esto indica que hubo un error al procesar el servicio en el servidor.
El procesamiento se anula con esta ocurrencia, informando a [FAULT_CODE] el código de excepción SOAP, en <URL> el servidor WebServices que devolvió el paquete y, en FAULT_STRING más detalles sobre la ocurrencia.

Esta ocurrencia es capturada por el propio código fuente del método, y el método 'Client' llamado devuelve .F. (false), y la descripción de la ocurrencia debe recuperarse a través de la función GetWSCError().

En la mayoría de los casos, este error se produce porque, cuando se solicita, el servicio probablemente realizó una rutina protheus donde se generó un error interno. Se recomienda la migración para evaluar el proceso .log consola y buscar un posible error.log por ejemplo.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _