Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) MI - REST - Variable does not exist CFILANT on SUPERGETMV

time.png Tiempo aproximado de lectura: 00:05:00 min

Ocurrencia
Al ejecutar un API con mas de una empresa el sistema retorna el error "Variable does not exist CFILANT on SUPERGETMV"

Ambiente
FRAMEWORK - Framework (Línea Protheus) MI - REST - Todas las versiones 12 

Causa
El sistema no puede localizar la sucursal CFILANT para iniciar sesión en el sistema.

Solución

En la configuración de Rest en el Appserver.ini en la sección [HTTPUTRI] debe agregar la clave PreparaIn = All o PrepareIn = Company, Branch que ha iniciado sesión para que el sistema valide la rama que ha iniciado sesión en el sistema, como se muestra a continuación:

[HTTPURI]
URL=/rest
PrepareIn=All
; PrepareIn=T1,D MG 02
;dasboardInstances=1.2
;Instances=4,4,1,1
Instances=2,5,1,1
;Instances=1.10
CORSEnable=1
AllowOrigin=*

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _