Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - MATA462N - Se identifica que la Opción de anulación y borrado de remito de Venta realizan la misma afectación en tablas del sistema

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocorrência
En módulo Facturación en rutina MATA462n-Remito de Venta, se identifica que al validar las opciones "Borrar" y "Anular" en la rutina de generación de remitos de venta (MATA462N), se observa que ambas opciones realizan la misma acción, actualizan el campo D_E_L_E_T en los registros e informa la fecha F2_DTCANC y F2_OBSERV de la misma manera; sin realizar alguna acción diferente entre ambas opciones.

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - Versión 12

Causa
Este comportamiento ocurre por inconsistencias a nivel código, por lo que se implementa en el fuente de notas fiscales (LOCXNF) en la función LocxDelNF, en la sección donde es actualizado los campos F2_OBSERV F2_DTCANC, una condición, para que solo cuando es efectuada una anulación los campos F2_DTCANC y F2_OBSERV sean afectados.  

Solución

Para solucionar esta ocurrencia realice los siguientes pasos:

1. Garantice tener compilada en su repositorio la rutina LOCXNF con fecha igual o superior al 18/07/2022.

2. En caso de que tenga fecha menor a la indicada en el punto 1 de alguna de las rutinas, solicite a soporte técnico la actualización de la rutina vía ticket, ISSUE DMICNS-14519.
3. Aplique el PATCH correspondiente con previo respaldo de su RPO y valide el escenario.

Conozca más

Para mayor información referente a la corrección realizada consulte el Boletín Técnico:

TDN - DMICNS-14519 DT Anulacion de remitos ARG

Consulte el proceso para aplicación de PATCH:

Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _