Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - GPER884-Al generar el XML de una indemnización el recibo se genera en blanco



time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia
En el módulo de Gestión de Personal (SIGAGPE) al intentar timbrar una indemnización, está generando 1 XML con los ingresos ordinarios de forma correcta, pero el XML de la indemnización no lo arma adecuadamente, es decir al abrirlo aparece en blanco:

mceclip0.png


Ambiente
TOTVS RH - TOTVS RH (Línea Protheus) - MI - Gestión de Personal (SIGAGPE) - versión 12

Causa
El XML contiene caracteres especiales en el atributo NumAñosServicio, ejemplo:

mceclip1.png


Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:
1. Valide que en su archivo .ini tenga caracteres especiales en el atributo NumAñosServicio, ejemplo:

mceclip2.png


2. Realice un respaldo de su archivo GPER884.ini en el caso de CFDI 3.3 o GPER88440.ini en el caso de CFDI 4.0;

3. Modifique la Linea de su archivo ini,  donde se encuentra declarado el atributo NumAñosServicio por la siguiente:

(PRE) _aTotal[002] += ' NumAñosServicio="' + Alltrim(Str(IIf(nNumAnios==0, 1, nNumAnios))) + '"'

Ejemplo de como deberá quedar:

mceclip3.png

3. Genere nuevamente el XML y valide que se haya formado correctamente.
 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _