Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - MATA465n error.log "array out of bounds ( 2 of 1 ) on MAFISRET(MATXFIS.PRX)" NCC vinculada a NF con más de 1 ítem con impuesto IB4

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
En módulo Facturación, para ambiente de localización Argentina se detona error.log "array out of bounds ( 2 of 1 )  on MAFISRET(MATXFIS.PRX)" cuando se genera una NCC vinculada a una NF con más de 1 ítem y utilizando TES con cálculo de impuesto IB4.

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) - A partir de versión 12.1.27

Causa
Este incidente ocurre por inconsistencias a nivel código, en la rutina de cálculo de impuesto M100XIBP.

Solución
Para solucionar esta ocurrencia realice los siguientes pasos:
1. Garantice tener compilada en su repositorio la fecha de la rutina M100XIBPcon fecha igual o superior a 27/06/2022 .
2. En caso de que tenga fecha menor a la indicada en el punto 1 de alguna de las rutinas, solicite a soporte técnico la actualización de la rutina vía ticket, ISSUE DMICNS-14589.
3. Aplique el PATCH correspondiente con previo respaldo de su RPO y valide el escenario.

 

Conozca más

Para mayor información referente a la corrección realizada consulte el Boletín Técnico:

TDN - DMICNS-14589 DT IB4 en NCC con varios ítems en base a NF ARG

Consulte el proceso para aplicación de PATCH:

Aplicación de Patch con Visual Studio Code (VS Code)

Se adjuntan PATCH puntuales liberados para el ISSUE DMICNS-14589 para su descarga en la versión/release de su ambiente.
PACOTE_DE_CORRECAO_14523711_DMICNS-14589_12.1.27.ZIP

PACOTE_DE_CORRECAO_14523711_DMICNS-14589_12.1.33.ZIP

 

Importante: Los patch´s adjuntos contienen la ultima versión de las rutinas liberadas en el ISSUE correspondiente, hasta la fecha de la publicación del presente articulo 27/06/2022; por lo cual en caso de requerir alguna versión más actualizada, es importante considere entrar en contacto con el área de soporte, con el fin de confirmar si existe algún actualización posterior.

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _