Tiempo aproximado para lectura: 1:30 min
Ocurrencia
Al levantar el servicio de TSS por primera vez luego de una actualización de versión, ocurre un error de conexión con el banco de datos:
Error - TOPCONN - No connection: -2 - NO_CONNECTION
Connection failed - DataBase:MSSQL Server:LOCALHOST Port:0

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Facturación (SIGAFAT) – A partir de Versión 12.1.27
Causa
El problema de conexión ocurre porque la DBAPI de TSS se encuentra desactualizada.
Solución
Para solucionar esta ocurrencia, actualice la DBAPI en la carpeta AppServer de TSS siguiendo el procedimiento descrito en el siguiente documento: Cómo actualizar la biblioteca DBAPI
Conozca más
Para adquirir más conocimiento, acceda al siguiente enlace:
TDN: Mejoría - DBAccess no aceptará conexiones de una DBAPI desactualizada
0 Comentarios