Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA143-array out of bounds ( 0 of 0 ) on MAFISENDLOAD(MATXFIS.PRX)



time.png TIempo aproximado para lectura: 00:03:00 min

Ocurrencia
En el módulo de Compras, al tratar de visualizar o modificar un despacho, desde la rutina MATA143 genera el siguiente errorlog:

array out of bounds ( 0 of 0 ) on MAFISENDLOAD(MATXFIS.PRX)

mceclip0.png

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - versión 12.1.33

Causa
Inconsistencia en las tablas DBA, DBB y DBC.

Solución

Para solucionar esa ocurrencia, realice los siguientes pasos:

1. Valide tener actualizados sus binarios con las últimas versiones disponibles del portal, recuerde realizar respaldo de las carpetas correspondientes a sus binarios, antes de actualizar;

APPSERVER
https://suporte.totvs.com/portal/p/10098/download#000006/368/TFAPP/


SMARTCLIENT
https://suporte.totvs.com/portal/p/10098/download#000006/368/TFSC/


2. Aplique la última LIB disponible, con previo respaldo de su RPO;

https://suporte.totvs.com/portal/p/10098/download#000006/368/TFLIB/


3. Realice un respaldo de las tablas DBA, DBB y DBC;

4. Dropee las tablas DBA, DBB y DBC;

5. Ingrese a la rutina de despachos (MATA143) para regenerar las tablas;

6. Incluya un nuevo registro de despacho y valide que una vez guardado, le permita modificar;

7. Appende los datos respaldados en el paso 3  correspondientes a las tablas DBA, DBB y DBC;

8. Valide que le permita modificar y visualizar los despachos de los registros appendados;

 

CONOZCA MÁS


Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Compras (SIGACOM) - Error al visualizar despacho - array out of bounds ( 0 of 0 ) on MAFISENDLOAD(MATXFIS.PRX)

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _