Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - ADVPL - Error.log: "There is a source name conflict <<(RUTINA.PRW)>> that prevents continuing securely. on EXISTBLOCK(APLIB190.PRW)"

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - ADVPL - Error.log: "There is a source name conflict <<(RUTINA.PRW)>> that prevents continuing securely. on EXISTBLOCK(APLIB190.PRW)"

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
En sistema Protheus, se detona error.log: "There is a source name conflict <<(RUTINA.PRW)>> that prevents continuing securely. on EXISTBLOCK(APLIB190.PRW)" en la ejecución de una rutina del sistema.

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - ADVPL - Versión 12

Causa
Este incidente se presenta cuando hay una sobre escritura del fuente padrón, en la llamada a una función de usuario .PRW

Solución

Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Inicialmente identifique en el log de error, en el STACK de la función "EXISTBLOCK" el nombre de la función que está generando el error.log

mceclip1.png
2. En el caso del ejemplo, el nombre de la función de usuario U_OMSA040 entra en conflicto porque el repositorio de objetos padrón tiene una rutina con el mismo nombre.
3. Luego de ubicar la función de Usuario, verifique el proceso deshabilitando Puntos de Entrada, cláusula IXBLOG=NORUN y confirme que de esta forma el error no se presenta.

Configuración y uso de clave IXBLOG

4. Si su requerimiento es tener compilada la función de usuario, modifique el nombre: Por ejemplo, PE_OMSA040.PRW y vuelva a hacer la compilación en su repositorio.

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _