Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Línea Protheus) - MI – Gestión de Personal (SIGAGPE) - Error al timbrar complemento de nómina – (GPER908)



time.png Tiempo aproximado para lectura: 00:03:00 min

Ocurrencia

Error al timbrar se muestra el siguiente mensaje:

TimbradoFormasDigitales 2.0.3.0
0010 Obtiene TFD 2920221201_01100035.xml 20/05/2022 01:42:36 p. m.
0110 Error al timbrar: com.forcogsa.exceptions.WSForcogsaException: Que el rango de la fecha generación no sea mayor a 72 horas para emisión del timbre.



Ambiente
Cross Segmentos Totvs Back Office (Línea Protheus) MI – Protheus 12.1.27

Causa

1.- Los servidores fueron cambiado de ubicación u hora: Hubo cambios en el acceso de smartclient o servidor de aplicación.

2.- La fecha y hora del archivo no corresponden con la fecha y hora de timbrado en el SAT.



Solución

Evalúe actualizando la función (Time) por (GetRmtTime) en el archivo INI
Por ejemplo: Se realiza el ajuste en archivo (GPER884).

La línea del archivo GPER884 estaba de la siguiente manera:

(PRE) _aTotal[076] := StrZero(Year(Date()),4) + "-" + StrZero(Month(Date()),2) + "-" + StrZero(Day(Date()),2) + "T" + Time()

 

Se realiza el cambio para usar la función (GetRmtTime) y se tome la hora de la maquina cliente.

(PRE) _aTotal[076] := StrZero(Year(Date()),4) + "-" + StrZero(Month(Date()),2) + "-" + StrZero(Day(Date()),2) + "T" + GetRmtTime()

 

kcs5.png

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _