Tiempo aproximado para lectura: 2:00 min
Ocurrencia
Al intentar aprobar un presupuesto de venta a través del ExecAuto de la rutina MATA416 siguiendo el ejemplo documentado en TDN, se muestra el Help A410CLIOK que indica: No se puede modificar el Número del Cliente o el Número de la Sucursal del mismo. Luego se muestra el Help NUMSEQ que indica: El número secuencial de este documento fue modificado, ya que otro usuario recién lo grabó.
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Facturación (SIGAFAT) - Versión12
Causa
Estos mensajes ocurren por inconsistencia en la numeración de los pedidos de venta en la tabla SC5, ya que, en la generación automática del pedido de venta luego de aprobar el presupuesto por ExecAuto, el Sistema asigna un número de pedido que ya está grabado.
Solución
Para solucionar esta ocurrencia, verifique la correcta secuencia de numeración de pedidos de venta en la tabla SC5 a través de la rutina de Control de Numeración en el Configurador del Sistema.
Para cerciorarse que los consecutivos están correctos, garantice que el Sistema sugiera el próximo número correctamente al intentar incluir un pedido de venta manualmente.
Importante
Para evitar problemas de numeración en ambientes de prueba que utilizan un mismo License Server, se sugiere utilizar la clave SpecialKey en el archivo de configuración appserver.ini.
Conozca más
Para adquirir más conocimiento, acceda a los siguiente enlaces:
TDN: Numeración automática por License Server
TDN: Clave SpecialKey
TDN: ExecAuto MATA146 - Aprobación automática de presupuestos
0 Comentarios