FAQs - Suporte técnico

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA447 - array out of bounds ( 0 of 1 ) on MT447CALCULO(MATA447.PRW) 11/11/2020 09:31:07 line : 5358 - Dos ítems uno activo y otro deletado mismo RSF_PRODUC diferente RSF_CAN


time.png Tiempo aproximado para lectura: 00:10:00 min

Ocurrencia
En el módulo de Compras (SIGACOM) al incluir un nuevo Pedimento (MATA447), en la pestaña de ítems de facturas, con dos ítems uno activo y otro deletado mismo código de producto (RSF_PRODUC) pero diferente cantidad (RSF_CANT), Precio (RSF_PRECIO)  y Total (RSF_TOTAL) y uno de ellos se encuentra eliminado, al presionar la tecla <F9>, se presenta el siguiente erro.log:


array out of bounds ( 0 of 1 ) on MT447CALCULO(MATA447.PRW) 11/11/2020 09:31:07 line : 5358



Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12


Causa
Este incidente puede ocurrir por desactualización de la rutina MATA447.



Solución

Para solucionar esta ocurrencia, realice los siguientes pasos:

1. Garantice tener la fecha de la rutina MATA447 con fecha igual o superior al 07/01/2022, caso contrario, solicite a soporte Protheus Mercado Internacional vía ticket la actualización de la rutina (DMINA-14592), aplique en su ambiente de pruebas con previo respaldo del RPO;



2.
Una vez aplicadas las actualizaciones, valide la inclusión de nuevos ítems de facturas, verificando que no sea generado el error.log.


Se realiza ajuste en la función MT447LOk2() para llenar correctamente el campo Ítem Docto. (RSF_ITEDOC) con el valor del campo Item (RSE_ITEM) para evitar error.log que se presentaba al presionar la tecla <F9> cuando existen más de un ítem para el mismo código de Producto pero uno de los ítems se encuentra eliminado.

13122973 DMINA-14592 DT Actualización de campo RSF_CANUM2 al informar el campo RSF_CANT en detalle de Fact. de Pedimento con Producto con Factor de Conversión MEX



Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces: Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA447 - ¿Cuál es el proceso para el registro de cada pestaña en pedimentos de importación?

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _