Tiempo aproximado para lectura: 00:10:00 min
Ocurrencia
En el módulo de Compras (SIGACOM) al incluir un nuevo Pedimento (MATA447), en la pestaña de ítems de facturas, con dos ítems uno activo y otro deletado mismo código de producto (RSF_PRODUC) pero diferente cantidad (RSF_CANT), Precio (RSF_PRECIO) y Total (RSF_TOTAL) y uno de ellos se encuentra eliminado, al presionar la tecla <F9>, se presenta el siguiente erro.log:
array out of bounds ( 0 of 1 ) on MT447CALCULO(MATA447.PRW) 11/11/2020 09:31:07 line : 5358
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - Versión 12
Causa
Este incidente puede ocurrir por desactualización de la rutina MATA447.
Solución
Para solucionar esta ocurrencia, realice los siguientes pasos:
1. Garantice tener la fecha de la rutina MATA447 con fecha igual o superior al 07/01/2022, caso contrario, solicite a soporte Protheus Mercado Internacional vía ticket la actualización de la rutina (DMINA-14592), aplique en su ambiente de pruebas con previo respaldo del RPO;
2. Una vez aplicadas las actualizaciones, valide la inclusión de nuevos ítems de facturas, verificando que no sea generado el error.log.
Se realiza ajuste en la función MT447LOk2() para llenar correctamente el campo Ítem Docto. (RSF_ITEDOC) con el valor del campo Item (RSE_ITEM) para evitar error.log que se presentaba al presionar la tecla <F9> cuando existen más de un ítem para el mismo código de Producto pero uno de los ítems se encuentra eliminado.
13122973 DMINA-14592 DT Actualización de campo RSF_CANUM2 al informar el campo RSF_CANT en detalle de Fact. de Pedimento con Producto con Factor de Conversión MEX
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces: Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Compras (SIGACOM) - MATA447 - ¿Cuál es el proceso para el registro de cada pestaña en pedimentos de importación?
0 Comentarios