Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Libros Fiscales (SIGAFIS) - LOCARG – SIRCAR - Error : 208 (42S02) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid object name 'SD2T10'

time.png Tiempo aproximado para lectura: 00:01:30 min

Ocurrencia
Se identifica error en la rutina LOCARG – SIRCAR; al tratar de generar el TXT de la normativa se produce un error log: Error : 208 (42S02) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Invalid object name 'SD2T10'. ( From tMSSQLConnection::GetQueryFile ).

 

mceclip0.png

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) MI - Libros Fiscales (SIGAFIS) - Versión 12

Causa
Este incidente se produce debido a que en el fuente de la rutina LOCARG en la función CFOSIRCAR se dejo fija la sucursal T10 en el query.

Solución
Para solucionar esta ocurrencia, se realiza la corrección para utilizar la función RetsqlName para traer el nombre correcto de las tablas SF1,SD2,SD1, realice los siguientes pasos.
1. Verifique tener las versiones de las siguientes rutinas con fecha igual o superior:

LOCARG-22/12/2021
MATA950-22/09/2021
MATXMAG-07/12/2021
2. En caso de que tenga fecha menor a esta, solicite a soporte técnico la actualización de la rutina vía ticket, ISSUE DMICNS-13108
3. Aplicar las actualizaciones en  ambiente de pruebas inicialmente, con previo respaldo del RPO para actualizar sólo fuentes

4. Validar que luego de aplicar las actualizaciones es posible realizar la generación del txt.

 

Conozca más:

Consulte la información del Boletín Técnico

TDN - DMICNS-13108 DT Error log TXT SIRCAR ARG

Para mayor información referente a aplicación de PATCH, le recomendamos revisar el siguiente artículo:
MP - CFG - Aplicación de Patch con Visual Studio Code (VS Code)

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _