Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - CFGA520 - invalid macro source (SSYacc0105e: Error token failed, no valid token):(STATICCALL(FUNCTION,MenuDef)) on GETMENUACS(APCFG40.PRW) 08/04/2021 17:34:12 line : 1099


time.png Tiempo aproximado para lectura: 00:10:00 min

Ocurrencia

En el modulo de Configurador (SIGACFG) al ingresar a generar el informe de grupo de usuario (CFGR510) a través de la rutina Grupo (CFGA520) se presenta un error.log


invalid macro source (SSYacc0105e: Error token failed, no valid token):(STATICCALL(FUNCTION,MenuDef)) on GETMENUACS(APCFG40.PRW) 08/04/2021 17:34:12 line : 1099

 

 

Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - Versión 12133


Causa
Este incidente puede ser originado porque se ingreso una opción de menú, por fuera del modulo del configurador  vía TXT, por integrar una opción de menú para alguna customización de cliente o bien por corrupción del menú.  


Solución
Para solucionar la ocurrencia realice los siguientes pasos:

1. Copie el log completo del error mostrado en la rutina de Protheus en un bloc de notas, después localice la línea STACK GETMENUACS(APCFG40.PRW);


2. En la variable CROTINA se indica la rutina que esta originado el error.log y en la variable M_ARQMENU(C) se indica el menú donde esta dado de alta la opción;

  • Por ejemplo en este error.log es originado con tener un programa de usuario dado de alta en el menú del modulo de Contabilidad de Gestión (SIGACTB);

mceclip0.png

mceclip1.png


3. Desde el modulo del configurador quite la opción del menú de la rutina (Programa) de usuario, se anexa el link del siguiente articulo con un ejemplo de como retirar la opción de menú;




4.  Genere el informe de la rutina el informe de grupo de usuario (CFGR510) a través de la rutina Grupo (CFGA520), con esta validación verificamos si el error.log es originado por la customización de usuario;

mceclip3.png

mceclip4.png

mceclip5.png



5. Posterior a garantizar generar el informe, vuelva a dar de alta la opción del programa de usuario en el menú donde lo retiro, a través de la rutina de menús desde el modulo del configurador, se anexa el link del siguiente articulo de ejemplo;



6.- Ponemos tambien a su disposición, la opción de reestablecer los menús padrón del sistema Protheus, donde deberá descargar el archivo de menús disponibles en el portal del cliente, colocar los archivos con extensión .xnu en el system de su ambiente de pruebas, después en la rutina de menú presione el botón de Restaurar.

mceclip6.png






Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces: Help On-Line - Grupo (CFGA520)

Help On-Line - Menú (CFGX013)

 

 

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _