Tiempo aproximado para lectura: 00:10:00 min
Ocurrencia
En el modulo de Configurador (SIGACFG) al ingresar a generar el informe de grupo de usuario (CFGR510) a través de la rutina Grupo (CFGA520) se presenta un error.log
invalid macro source (SSYacc0105e: Error token failed, no valid token):(STATICCALL(FUNCTION,MenuDef)) on GETMENUACS(APCFG40.PRW) 08/04/2021 17:34:12 line : 1099
Ambiente
Cross Segmentos - TOTVS BackOffice (Línea Protheus) - MI - Configurador (SIGACFG) - Versión 12133
Causa
Este incidente puede ser originado porque se ingreso una opción de menú, por fuera del modulo del configurador vía TXT, por integrar una opción de menú para alguna customización de cliente o bien por corrupción del menú.
Solución
Para solucionar la ocurrencia realice los siguientes pasos:
1. Copie el log completo del error mostrado en la rutina de Protheus en un bloc de notas, después localice la línea STACK GETMENUACS(APCFG40.PRW);
2. En la variable CROTINA se indica la rutina que esta originado el error.log y en la variable M_ARQMENU(C) se indica el menú donde esta dado de alta la opción;
- Por ejemplo en este error.log es originado con tener un programa de usuario dado de alta en el menú del modulo de Contabilidad de Gestión (SIGACTB);


3. Desde el modulo del configurador quite la opción del menú de la rutina (Programa) de usuario, se anexa el link del siguiente articulo con un ejemplo de como retirar la opción de menú;
4. Genere el informe de la rutina el informe de grupo de usuario (CFGR510) a través de la rutina Grupo (CFGA520), con esta validación verificamos si el error.log es originado por la customización de usuario;


5. Posterior a garantizar generar el informe, vuelva a dar de alta la opción del programa de usuario en el menú donde lo retiro, a través de la rutina de menús desde el modulo del configurador, se anexa el link del siguiente articulo de ejemplo;
6.- Ponemos tambien a su disposición, la opción de reestablecer los menús padrón del sistema Protheus, donde deberá descargar el archivo de menús disponibles en el portal del cliente, colocar los archivos con extensión .xnu en el system de su ambiente de pruebas, después en la rutina de menú presione el botón de Restaurar.
Conozca más:
Para consultar la información contenida en nuestro banco de conocimientos, acceda a los siguientes enlaces: Help On-Line - Grupo (CFGA520)
0 Comentarios