Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

FRAMEWORK - Framework (Línea Protheus) - MI - DBAccess - Connection blocked. The DBAPI used on the application server is out of date


time.png Tiempo aproximado para lectura: 1:30 min

Ocurrencia
Luego de actualizar TOTVS | DBAccess e intentar utilizar TOTVS | DBMonitor o intentar ingresar en el ambiente Protheus, se presenta el siguiente mensaje en consola de TOTVS | DBAccess: [tSockDBServer][ERROR] Connection blocked. The DBAPI [20191119] used on the application server is out of date.

Ambiente
FRAMEWORK - Framework (Línea Protheus) - MI - DBAccess - Versión 12

Causa
A partir del release 21.1.1.0 de TOTVS | DBAccess, fue implementada la validación para bloquear conexiones que se originen de un TOTVS | Application Server que esté utilizando una DBAPI desactualizada.

Solución
Para solucionar esta ocurrencia, actualice la DBAPI en todos los AppServers que conectan a TOTVS | DBAccess siguiendo el procedimiento descrito en el siguiente documento: Cómo actualizar la biblioteca DBAPI

Conozca más
Para adquirir más conocimiento, acceda al siguiente enlace:
TDN: Mejoría - DBAccess no aceptará conexiones de una DBAPI desactualizada

¿Fue útil este artículo?
Usuarios a los que les pareció útil: 0 de 0

0 Comentarios

Inicie sesión para dejar un comentario.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Rellene los campos siguientes para iniciar el chat:

Chat _